Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 3
Registered: ‎07-24-2012
My Device: Bold
My Carrier: Verizon
Accepted Solution

Blackberry Eclipse Plugin

I need some assistance with installing the Blackberry Eclipse Plugin.

 

In May, I successfully downloaded the all-in-one eclipse and Blackberry plug-in 7.0. I had a lot of difficulty then, but now with the new release 7.1, my previous solution is not working (which was re-adding the plugin through the update site in eclipse) I believe.

 

The problem I am having is eclipse installs fine, but it won't recognize the blackberry features - ie it doesn't have the "blackberry perspective" or "blackberry project" or any simulator items. The component pack and simulator files are all in the directory.

 

I have tried:

-Installing the all-in-one plug-in on (where there are no other eclipse installations).

 

-Installing basic eclipse 3.7 x86, then attempting to use the update site http://www.blackberry.com/developers/jar/win/java

(sometimes this link won't connect, but I got it to connect once so that I could install the core plug-in and BB SDK 7.1) - still will not recognize the blackberry features.

 

Technology used: Windows 7 x64, Jre 6 x86

 

Any help would be GREATLY appreciated!!!

 


New Contributor
Posts: 3
Registered: ‎07-24-2012
My Device: Bold
My Carrier: Verizon

Re: Blackberry Eclipse Plugin

I should also probably mention, that the reason I have to re-install the blackberry plugin is because I had to upgrade my pc from xp to Win 7. So I lost the previous install and all the painstaking configurations! Smiley Happy

Highlighted
New Contributor
Posts: 3
Registered: ‎07-24-2012
My Device: Bold
My Carrier: Verizon

Re: Blackberry Eclipse Plugin

I solved my own problem:

 

Why this is like this, I have no idea, but if you want to "activate" the Blackberry features you must go to "Run Configurations" - The below screen will pop-up > select "Add Required Plug-ins" on the right hand side, it should populate all the plugins you have downloaded, then hit run. It will open a new instance of eclipse with all of the blackberry features.