Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Visitor
Posts: 1
Registered: ‎09-12-2012
My Device: Blackberry storm
My Carrier: BSNL

Blackberry JDE 6 & 7 installation issue

I downloaded Blackberry JDE 6 and 7 from the site https://developer.blackberry.com/java/download/previousjdeversions/

 

After downloading when I try to install, both 6 and 7 have same problem, have restarted my pc also, still no solution

 

This is what happens:

 

In the prerequisite section it shows 3 text boxes

 

Name - Version - Action
JDK - Required 1.5 or higher found 1.6 1.6.0_26 - Skip

Direct X - Required 4.08 found 4.09.00.0904 -Skip

Microsoft Visual C++ 2008 Redistributable Package (x86) - Required any Found nothing-install

 

Now by default Microsoft Visual C++ 2008 Redistributable Package (x86) is checked when I click Next, it extracts the package and status shows as installed but at the bottom of screen it shows error with message "After launching all packages some required prerequisites are still missing, Press back button to return to prerequisites"

when I click back button it goes back to the prerequisites page with checkboxes showing JDK Directx and Microsoft Visual C++ and clicking next has the same problem- shows installed but with error message

 

When I check the other two, for JDK and directx it opens browser with two tabs, one with oracle for jdk download, and the other with microsoft direct x

After I click next it does the same as before, by extracting package for Microsoft Visual C++ and status shows as installed but at the bottom of screen it shows error with message "After launching all packages some required prerequisites are still missing, Press back button to return to prerequisites"

 

In my friends computer it installed fine and launched the blackberry emulator, both my friends and my computer run windows 7

Please give a solution to this problem

Retired
Posts: 138
Registered: ‎05-11-2012
My Device: Developer
My Carrier: Developer

Re: Blackberry JDE 6 & 7 installation issue

Are you trying to install Momentix Development environment or is this just a Java environment you are trying to

install?

 

Graham

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Blackberry JDE 6 & 7 installation issue

Can I honestly recommend that you give Eclipse a shot rather than JDE.  I used to only use JDE but was forced to use Eclipse to do something recently and now avoid JDE...

 

I'm going to try testing your problem a bit later.  But can you tell me

 

a) Are you running the install as an Administrator?

b) Are you 64 bit or 32 bit Win 7

c) Are you running 32 bit java or 64 bit?

d) Have you tried downloading and installing the 2008 redistributable independently before starting the JDE install?

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Blackberry JDE 6 & 7 installation issue

I installed JDE 6.0, got the same requirements message, but it installed it OK.

 

It seemed to have installed this:

http://www.microsoft.com/en-us/download/details.aspx?id=5582&WT.mc_id=MSCOM_EN_US_DLC_DETAILS_131Z4E...

 

I would try to download and install this, then try the JDE install again. 

 

Let us know how hyou get on.

Retired
Posts: 138
Registered: ‎05-11-2012
My Device: Developer
My Carrier: Developer

Re: Blackberry JDE 6 & 7 installation issue

Are you still having problems

 

Regards

Graham