Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 455
Registered: ‎03-04-2011
My Device: Paper cup

Breakpoints stopped working (JDE)

Breakpoints stopped working.  JDE 5 with 9550 sim.  Tried it also in JDE 6 with 9800 sim, same thing.


Cleaned everything.  Ran the clean script in the sim directory that took about half an hour to complete.


Rebuilt everything a dozen times.  Debugger is attached, because Break Now stops the sim.


But breakpoints do not work. They set, but never trigger.  Anywhere.  Not even the 1st line of main().


I can't debug this complex app without breakpoints, and on-device doesn't give enough info, so any ideas would be appreciated. Short of wiping and reinstalling the computer, I am stumped!


Thank you...


Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Breakpoints stopped working (JDE)

Sorry no real ideas. 


I would try it on a simple project.  I would make sure I tried it on the xxx-JDE Simulators that come with the JDE rather than ones added. 


I have deleted and reinstalled the JDE sometimes.  I think if you don't clear out the associated directory it doesn't loose anything, but don't quote me on that. 


Being honest here, this has actually happened to me a few times like this.  I have opened one project, swapped to another project to display some source, closed the source in the other project and so are displaying the source for the original project, then Build and of course it builds the wrong project.  Then none of the breakpoints match because I have not recompiled my project, it was still swapped to the other project.  I felt pretty stupid when I figured this out.....


But doesn't sound like you are doing this.  Sorry I can't help more.

Posts: 455
Registered: ‎03-04-2011
My Device: Paper cup

Re: Breakpoints stopped working (JDE)

[ Edited ]

It seems to be the preprocessor that's breaking the breakpoints.

I removed (very tediously) all #ifdef blocks and #preprocess, and now the breakpoints work.

Has anyone gotten breakpoints to work while using #preprocess to separate the trial and full versions?





Yes, I've confirmed it now.   Removing use of the preprocessor fixed the problem.