Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 201
Registered: ‎12-17-2010
My Device: Not Specified

Browserfield Issue

Hello Friends,

 

I have to open below url in the browserfield I tried a lot but I was getting only one respose [ No Canvas Support].

below is the code.

 

String strUrl = "http://www.ihealthrevolutionapp.com/weightloss/graphAPI.php?xAxisTitle=Day&yAxisTitle=BMI&graphColor...";

        BrowserFieldConfig myBrowserFieldConfig = new BrowserFieldConfig();
        myBrowserFieldConfig.setProperty(BrowserFieldConfig.NAVIGATION_MODE,
                BrowserFieldConfig.NAVIGATION_MODE_POINTER);
        myBrowserFieldConfig.setProperty(BrowserFieldConfig.JAVASCRIPT_ENABLED,
                Boolean.TRUE);
        
        BrowserField browserField = new BrowserField(myBrowserFieldConfig);

        browserField.requestContent(strUrl);

       add(browserField);

 

I think its issue of javascript.If any one has any idea please help me.

Thanks ,

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Browserfield Issue

I get the response:

"[No canvas support] "

When I try that URL in IE8.  But it works in Mozilla 9.  So I suspect you are trying to use some facility that is not available in the BlackBerry BrowserField.

 

What OS levels have you tried this with?

Developer
Posts: 201
Registered: ‎12-17-2010
My Device: Not Specified

Re: Browserfield Issue

Thanks look into my issue.

I tried it with os 5.0.

It works fine android.

that's why I post msg here..

If u have any idea plz suggest..

Thanks,

Milan 

 

Developer
Posts: 729
Registered: ‎05-04-2011
My Device: 9700

Re: Browserfield Issue

Hi @milanvishal,

 

It seems that your browserField have some problems displaying your HTML5 page.

 

You can try the following steps:

 

1. Try and convert your page to traditional HTML.

 

2. Consider using the external browser.

 

3. Try sniffing the response (or just print the HTML you got from the server) and compare it with a page returned from a different browser. If the content is different, it might be something different in the request.

 

4. Check if the issue happens when you are using wifi. I have seen cases where BIS/BES removes tags from HTML and damage the rendering. If it works correctly with wifi, try adding this http header to your request:

"x-rim-transcode: none"

This will cause the BIS/BES ignoring the content of your page and send it as is.

 

Hope that helps,

 

E.

 

Highlighted
Developer
Posts: 201
Registered: ‎12-17-2010
My Device: Not Specified

Re: Browserfield Issue

Hi,

Thanks for reply..

but the issue is I just have to open one url in browserfield..

I dont have to do more..