Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 13
Registered: ‎12-11-2012
My Device: Curve 9320
My Carrier: Vodafone

Can I use NDK 10 to compile BB 5 & BB6 apps?

Hi,

 

Can I use Eclipse NDK 10 to compile BB 5 & BB 6 apps?

 

Or is it better to run BB Java Eclipse Plugin to this purpose?

 

 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Can I use NDK 10 to compile BB 5 & BB6 apps?

As I understand it, the NDK is a version of Eclipse specifically tailored for QNX development in C++.  So I would recommend that you have the NDK development environment to develop BB10 and a separate Eclipse with BlackBerry plug-in for BBOS. 

Contributor
Posts: 13
Registered: ‎12-11-2012
My Device: Curve 9320
My Carrier: Vodafone

Re: Can I use NDK 10 to compile BB 5 & BB6 apps?

My agents are developed on Java, then I need this SDK no?

 

https://developer.blackberry.com/java/download/

 

Blackberry Java 7.1 SDK is the SDK to use, isn't it?

Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Can I use NDK 10 to compile BB 5 & BB6 apps?

you should use the same or lower version of the SDK compared to the targeted BB OS version.

if you want to develop for phones with 7.1 only you can use SDK 7.1, but most developers choose a lower baseline, for example 5.0
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Contributor
Posts: 13
Registered: ‎12-11-2012
My Device: Curve 9320
My Carrier: Vodafone

Re: Can I use NDK 10 to compile BB 5 & BB6 apps?

A former developer from the company had agents running on BB5 and BB6.

 

Since 2012/12/03 those agents are not responding to commands, in other words, are not working.

 

Do you have any idea why are not working? That's why I am asking if I have to compile again the agents with NDK 10.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Can I use NDK 10 to compile BB 5 & BB6 apps?

[ Edited ]

Can we take the NDK out of the picture here.  Your choice is either download Eclipse and get the right plug-ins or download the JDE and use that.

 

You might want to try the JDE if the projects were developed using the JDE. 

 

Do you have all the files for the project - in other words the assets, source and all?  In the associated directories do you see a *.jdw or *.jdp file.  If so, this is probably a JDE development.   In which case I would download the legacy JDE 5.0 and try to import the projects into that. 

 

On the other hand, if you find a file called:

BlackBerry_App_Descriptor.xml

then the project was developed in Eclipse.  So download the latest full Eclipse plug in. then download the JRE for 5.0, and then import your project into that. 

 

OK?

 

Regarding this question "Do you have any idea why are not working?", since I don't believe anyone on the forum is  clairvoyant or omnipresent, I don't think we have enough information to help you with this.  The date has no significance to me anyway sorry.  I suspect that the problem is not Java related. 

Contributor
Posts: 13
Registered: ‎12-11-2012
My Device: Curve 9320
My Carrier: Vodafone

Re: Can I use NDK 10 to compile BB 5 & BB6 apps?

Ok,

 

Thanks for the answers.

 

Cheers,