Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Developer
Posts: 13
Registered: ‎05-21-2009
My Device: Not Specified

Can't Debug with Eclipse Plug-in for Mac Tech Preview

I've got the Eclipse Plug-in for OSX installed and configured and I'm unable to get it to connect to the device (9800) via USB. I've installed the BlackBerry Desktop Manager so the USB drivers are available. The projects build and package without error. When I attempt to debug, immediately after the signature tool disappears I see "signing complete" in the console, then the screen on the device flashes very quickly and then nothing happens. It doesn't appear to be copying any of the COD files over to the device. If I view the debug configuration and select "attach to specific device" the connected device shows up so the device seems to be connected properly. Has anybody gotten this to work?

 

 

Regards,

 

Ambrose Krapacs

 

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Can't Debug with Eclipse Plug-in for Mac Tech Preview

I don't have a Mac but I had a similar issue with a Torch. Try rebooting the device then your computer.

 

If that does not work, enable Mass Storage Mode on the device. Those are the three steps I took to get Live Debugging to work and I believe Mass Storage Mode actually got it working.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Developer
Posts: 484
Registered: ‎07-17-2008
My Device: Not Specified

Re: Can't Debug with Eclipse Plug-in for Mac Tech Preview

No mac here either but I've had lots of trouble debugging with the Torch using the JDE.

 

It seems extremely flakey.

New Developer
Posts: 13
Registered: ‎05-21-2009
My Device: Not Specified

Re: Can't Debug with Eclipse Plug-in for Mac Tech Preview

I've tried rebooting both the device and my computet and still nothing. I even tried doing a security wipe on the device. It seems to be a problem with the plug-in. If I reboot into my Windows Bootcamp partition I can get it to attach to the debugger. I guess I'm still stuck with that...
Highlighted
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Can't Debug with Eclipse Plug-in for Mac Tech Preview

No Mac here either.

 

I'd say make an Issue Tracker log with the steps you did to install Eclipse, the Plug-in, the example code, Torch version, etc. I mean it is a beta, if you found a problem it's best to let them know know then when they say it's done.

 

One other idea; does it say what Eclipse version is required? Because on Windows you need 3.5 but people have tried to install 3.6 and all they get are errors, that might carry over to the Mac version. Just thinking.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.