Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 102
Registered: ‎07-15-2008
My Device: Not Specified
Accepted Solution

Can't close Simulator under Eclipse Plug In

Just migrated my application from JDE to the Eclipse plugin environment.  Application compiles fine and runs fine.  However, when I run it under the simulator I can never get the simulator to close.  I have to actually kill off Eclipse to stop the simulator.  

 

Windows 7-64, Eclipse Gallileo, Plug In 1.1.

 

Any ideas?

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Can't close Simulator under Eclipse Plug In

It is because you are running it on a 64-bit Windows 7. This issue was resolved in an update. I'm not sure if it fixes every simulator but it seems to have fixed the OS 5 simulator.

 

Go to Help > Install New Software.

 

If you have the update site set up (http://www.blackberry.com/go/eclipseUpdate/3.5/java), check "Hide items that are already installed".

 

Update "BlackBerry Java Plugin". As of this writing, the latest is marked 4-16-2010.

 

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Developer
Posts: 48
Registered: ‎07-28-2009
My Device: Tour 9630
My Carrier: V Dub

Re: Can't close Simulator under Eclipse Plug In

[ Edited ]

Hi Tim,

 

If updating the software doesn't solve your issue you can try using Windows Task Manager.

 

How I used it before the software update solved that issue was, if your not familiar with the Windows Task Manager.

 

1. On your keyboard press control+alt+delete your screen might go blank for a second or 5

 

2. Then there are a few options select start Task Manager.

 

3. from there in the Windows Task Manager window select the Applications tab.

 

4. then select the simulator from the list and press the End Task Button. it can take a second or two but that's better than killing eclipse entirely.

 

You can pin the Task manager to the taskbar.

 

What os version and  simulator is the issue with? If you woudnt mind.

 

Brent 

Highlighted
Contributor
Posts: 34
Registered: ‎03-14-2010
My Device: N/A
My Carrier: Fledge

Re: Can't close Simulator under Eclipse Plug In

I can't click the "x" or go file-close, however if I right click on the simulator in the task bar I can click "close" and it works.