Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 6
Registered: ‎09-21-2010
My Device: Not Specified
Accepted Solution

Can't install the BlackBerry Plugin for Eclipse

So I've been trying really hard to get this **bleep** installed for a while now, but nothing even mentions the problem that I'm having as far as I know.

 

I downloaded the BlackBerry plugin from the site. It's giant, it's called "BlackBerry_JDE_PluginFull_1.1.2.201004161203-16.exe"

I can't find any other file that seems to be the plugin so I'm guessing this is it. BUT when i run it, it pops up a dialog box that tells me to choose a different install path. The dialog box's title is InstallAnywhere. In the setup video it doesn't even show this step, so I'm guessing this is the problem....though I have no idea how to fix it. It just stays there if I choose anywhere on my computer.

 

I would really like to be past this step. Can anyone help me?

Developer
Posts: 172
Registered: ‎04-19-2010
My Device: Bold 9700

Re: Can't install the BlackBerry Plugin for Eclipse

Hi adiktofshugar,

 

I think, it is the right file. I'm using the same for my eclipse installation.

 

I think you already installed eclips and I thinkyou have not the right ecplise version to install it.

If you don't have the right one it shows a dialog like you told in your thread.

 

cu

michael

cu
michael
--------------------------------------------------------------------------------------------------------------------------
please give kudos to thank everyone who helped you or put you in the right direction.
please mark the thread as solved, if you found your solution.
New Contributor
Posts: 6
Registered: ‎09-21-2010
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

I have eclipse classic 3.5 installed, which is what I thought I needed. It seems like eclipse doesn't have any registry files though, so installed just means its on my computer somewhere. Does it have to be in a certain folder?

Developer
Posts: 172
Registered: ‎04-19-2010
My Device: Bold 9700

Re: Can't install the BlackBerry Plugin for Eclipse

[ Edited ]

Hi,

 

no you can unpack eclipse and put it on every place you want.

 

For me i created a tools folder on my desktop and put it in a subdirectory in there, so you can have more parallel installations/version of eclipse.

 

I've got the same message in the past, so i had to search for the right version.

 

If Galileo is not running, try Ganymede instead(3.4).

 

I'm using J2EE version of eclipse.

 

Cu

michael

cu
michael
--------------------------------------------------------------------------------------------------------------------------
please give kudos to thank everyone who helped you or put you in the right direction.
please mark the thread as solved, if you found your solution.
Developer
Posts: 94
Registered: ‎10-01-2009
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

 


adiktofsugar wrote:

I downloaded the BlackBerry plugin from the site. It's giant, it's called "BlackBerry_JDE_PluginFull_1.1.2.201004161203-16.exe"

[...] when i run it, it pops up a dialog box that tells me to choose a different install path. The dialog box's title is InstallAnywhere. In the setup video it doesn't even show this step


 

The setup video doesn't show every mistake you can make, no.  It would have to be a lot longer.

 

Remember what Mike said in the video: you can use the installer to add the plug-in to an existing eclipse installation, or you can use it to install eclipse and the plug-in together.  But he also said that the installer won't let you accidentally install over a previous installation of the plug-in.

 

Yes, when you run the executable you downloaded, it runs InstallAnywhere.  On its third screen, the installer asks you where you want to install.  If you give it a new directory name, it installs eclipse with the plug-in there.  If you give it an eclipse directory that does not have the plug-in, it installs the plug-in there.  If you give it an eclipse directory that has the plug-in already, it warns you that you're trying to overwrite an existing installation.  I tried all three cases, just to be sure, and they work as advertised.

 

Unless you have a good reason to a different eclipse 3.5 than the one the installer installs, I recommend that you delete your existing eclipse(s) and just let the installer install everything.  If you really want the plug-in added to the 3.5 classic from the eclipse website, make a brand-new copy before you run the installer.

New Contributor
Posts: 6
Registered: ‎09-21-2010
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

jMarc, that is what the documentation says!

 

I never actually get to the 3rd screen though, it just says "Choose a different location to extract the installer to," and no matter what folder I choose (not that I've tried them all, but I have tried both eclipse installations and random ones across my hard drives), it does nothing. I originally tried to install it without an eclipse package because that's what I understood. It really doesn't seem to do anything though, and I'm getting pretty disappointed.

Developer
Posts: 94
Registered: ‎10-01-2009
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

Hey, sorry adikt, that's gotta be really frustrating.  Since I didn't see the problem, I figured cleaning everything out and starting over would solve the problem, but I guess not.

 

So it's back to basics.  Could be a system incompatibility - please describe your system.  Mine is 32-bit Windows XP. There used to be problems with 64-bit systems, and with both Vista and 7, but I don't know if there still are.  If you're using those, check the forum.  Have you set any environment variables that might affect eclipse?  Where are you putting it?  Do you have permissions to install where you're telling it to?  On XP, I'm putting it at the root level - you can't do that in some OSes.  I'm using  a directory with no spaces in the path, although that shouldn't matter.

 

Could also be a corrupt installer, although it's hard to imagine how it would run at all if it were bad.  Still, check it.  Mine is the same file name as yours, and it's 386,073,072 bytes.

 

Please describe the error message in detail.  Somebody else on the forum may have seen it, or one of the BB guys can look it up for you.    The exact wording matters!

 

I don't understand your comment about not getting to the third screen.  The first screen is just a welcome, you hit next.   On the second screen, you have to accept the license agreement.  So you can't even specify a place to install until the third screen.

 

Since it doesn't seem to be anything obvious from what you've told us, we'll need a lot more detail if we're going to be able to be useful to you.

New Contributor
Posts: 6
Registered: ‎09-21-2010
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

Alright cool, I still don't know what the problem is but maybe this will help...

 

I have Windows XP Pro 32 bit, it's now located at the root level, C:/blackberry/JDE thing, and eclipse is in the same folder (c:/blackberry/eclipse). I have all permissions that windows allows.

 

The size of the file is 367 582 993 bytes, size on disk is a bit bigger.... Yours is larger. I guess I'll try downloading it again, but that takes forever because I have slow internet, so it may be some time before I talk on here again.

 

I don't get an error message. I only get a dialog box that says: "Please select another location to extract the installer to:" and I have a choose... button and a cancel button. It looks like a window pops up and then immediately following this dialog box pops up after it.

New Contributor
Posts: 6
Registered: ‎09-21-2010
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

Well actually, I'm not going to download it again...The advertised size on the download page is 368.168 MB. I downloaded it from http://na.blackberry.com/eng/developers/javaappdev/devtools.jsp, click the Download the BlackBerry Java Plug-in for Eclipse v1.1 (full installer) button below Top Tools. That's where they kept telling me to go in all of their documentation.

Highlighted
Developer
Posts: 94
Registered: ‎10-01-2009
My Device: Not Specified

Re: Can't install the BlackBerry Plugin for Eclipse

No, really, download it again.  "Properties" on my copy says "368 MB (386,073,072)".  I know it's painful, but your copy is too small.  You have the right link.

 

You aren't even getting to the install.  It's not telling you to install somewhere else, it's telling you to extract the installer somewhere else.  I don't know how you can run a corrupt self-extractor at all, but I think your symptom says the extraction is failing.  Saying it a little oddly, I admit...

 

FWIW, when I start the installer it extracts itself to a directory in Local Settings\Temp.