Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 61
Registered: ‎06-01-2009
My Device: Not Specified

Cannot install application in different version.

I have use JDE 4.6 to develop a software, and use BlackBerry desktop Manager 4.7 to install the program into the machine(Bold 9000). It always success.

 

Recently  I use another computer to test the installation. I download the BlackBerry desktop Manager 5.0, use the alx file that is create from JDE 4.6, install into the Bold 9000 --- It show me the application is not suitable for the phone and it will not be install. 

 

Is that I need to use BlackBerry desktop Manager 4.7 to install only?

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Cannot install application in different version.

I use DM 5.0 and can happily install to Bolds, Storms, etc etc.  So the version of your DM is not the issue here.

 

Did the PC have an order version of DM installed?  Have you tried to load other devices with this DM?

Highlighted
Developer
Posts: 1,474
Registered: ‎04-14-2009
My Device: Not Specified

Re: Cannot install application in different version.

[ Edited ]

1. Make sure your DM v5.0 points to the right ALX file (you won't believe the weird stuff that happens when you point it to, say, a ZIP file instead).

2. Try the old trick of deleting the vendor.xml file of the Desktop Manager. I belive the file is located somewhere under Program Files\Common Files\ Research In Motion\AppLoader.

 

Message Edited by klyubin on 05-10-2009 07:26 PM