Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 27
Registered: ‎08-20-2008
My Device: 8350i Curve

Changing icon

Not quite sure what's causing this, but I've loaded an application on an 8350i that works well with the exception of the icon used for the app. The icon for the application displays correctly after the app is installed.  Several hours or a day or two later it changes to the default blue square icon.  I've had some users actually see it revert back to the original icon.  It happened to my 8350i as well, but it came back after I changed my theme.  So I know the icon came over with the application, but seems to come and go for some reason.  Anyone else seeing this type of behavior?

BlackBerry Development Advisor
Posts: 15,700
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Changing icon

Do you know what action(s) are leading up to this?  Do you use the HomeScreen API to change the application's icon?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Contributor
Posts: 48
Registered: ‎02-19-2011
My Device: Not Specified

Re: Changing icon

I am having the same problem with my Java app in the BB 9800 Simulator.  At first my custom app icon comes up but after a while it goes back to some generic icon.  

 

This is an old post.  Did you get it fixed? 

Developer
Posts: 27
Registered: ‎08-20-2008
My Device: 8350i Curve

Re: Changing icon

Sorry, but it's been so long ago that I can't remember how we solved that.  We've gone through several models and haven't come across it since (that anyone's reported).  Sorry I couldn't be of any help.

New Developer
Posts: 19
Registered: ‎08-21-2009
My Device: Not Specified

Re: Changing icon

I ran into this issue as well. 

 

Setting the icon programmatically from inside the application seems to fix it.

 

I have the following line of code at the beginning of my program:

 

 

HomeScreen.updateIcon(bmp);

 Where bmp is a Bitmap object.