Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 11
Registered: ‎08-27-2010
My Device: Not Specified
Accepted Solution

Changing targetted JRE for an existing project

Hi,

 

I created a project which seems to be targetting the JRE 5.0.0 environment, how easy is it to change that to an earlier version of the JRE for earlier phones?  I am using the standard Eclipse with Blackberry Plugin setup.

 

Regards

Richard

Highlighted
Regular Contributor
Posts: 98
Registered: ‎08-31-2010
My Device: BB-9700
My Carrier: Airtel

Re: Changing targetted JRE for an existing project

It is based on the API's you have used in your application.

 

If you already installed the other JRE like 4.7 with your eclipse, you can change the version

Windows-Prefernce-BlackBerry JDE-Installed components

and change the version to 4.7. After this you just need to compile your project and you would know if you are getting any error or not.

 

Thanks

 

Regards

-Abhijit

 

Please mark kudos if you get the solution

Developer
Posts: 1,415
Registered: ‎07-30-2008
My Device: Not Specified

Re: Changing targetted JRE for an existing project

 

Personally I've gotten used to conditional compilation- when you call a BB API, note

how early it was introduced and at least use "#warning" if you know you need

stub code for earlier versions. I define something called RIM_OS_TGT and use g++

preprocessor which gives me all the familiar macro's from c++.

 

This works nice for maintenance unless there are severe architecture changes,

and in particular the browser fields were updated in 5.0.