Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 266
Registered: ‎04-24-2009
My Device: Not Specified
Accepted Solution

Client with error message starting application

I have a client that gets the following error message when starting my app.  I have checked and other people with the same model and operating system do not seem to be having trouble.  I had them delete the application and reinstall but it didn't seem to help.  I was wondering if anyone else has run into a similar problem.

 

 

Error starting application class.net.rim.device.api.ui.container grid field manager not found
error starting radical draw class.net.rim.device.api.ui.container grid field manager not found
Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Client with error message starting application

This is most likely a device OS version level that is too low for the compiler level that built the application.

 

New Member
Posts: 1
Registered: ‎09-22-2010
My Device: Not Specified

Re: Client with error message starting application

Did you ever figure this out? I have the same problem: class not found 'net.rim.device.api.ui.container.GridFieldManager'.  I updated my BB to the latest code: 5.0.0.602 (Platform 5.1.0.112) and still no luck.  

 

I'm fairly new to BB development, so I'm wondering what I'm missing, especially since it works in the simulator.  I have tried to test my app on this new phone (Bold 9700) and can't get it to run. Seems like the class loader should find a class that is distributed with the OS.

Developer
Posts: 266
Registered: ‎04-24-2009
My Device: Not Specified

Re: Client with error message starting application

My client has the same phone ans OS, 9700, 5.0.0.602.

 

It is compiled with the 5.0 JDE.

 

This may be an issue for RIM.

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Client with error message starting application

There is no GridFieldManager in 5.0

 

 

Developer
Posts: 266
Registered: ‎04-24-2009
My Device: Not Specified

Re: Client with error message starting application

I am afraid I disagree.  gridFieldManager shows up in my 5.0 API reference and the app works on all 5.0 OS's other than the one listed.  It does work on some 9700's.

Highlighted
Developer
Posts: 266
Registered: ‎04-24-2009
My Device: Not Specified

Re: Client with error message starting application

I submitted this to RIM.  They got back to me SUPER fast.  I was impressed with Garett.

 

Bad news, RIM forgot to include gridFieldManager in the 5.0.0.602 release for the 9700, which happens to be the current 9700 release for most carriers as far as I can tell.  They verified that older OS's are OK and the new OS 5.0.0,714 is OK.

 

Unfortunately, this is a very big problem for me.  To make it worse, I don't think App World has a way of sending out release notes to clients. VERY short sighted.  I think someone way over thought App Word and made it so complicated that it sucks for developers and our clients.

 

Thank you everyone for your input.  It is much appreciated.