Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 3
Registered: ‎11-17-2009
My Device: Not Specified
Accepted Solution

Compiler Error in Eclipse




I'm using Eclipse 3.4 with the BlackBerry JDE installed along with the 4.7 components.


I'm attempting to run an example application and it builds/compiles without error when I right-click on the project and select "Build."  However, when I right-click on the project and selec Run As --> BlackBerry Simulator, a new error appears in the "Problems" pane that prevents the application from running:



Description    Resource    Path    Location    Type
Error!: Error: java compiler failed: javac -source 1.3 -target 1.3 -g -O -d C:\DOCUME~1\asleson\LOCALS~1\Temp\rapc_447d336b.dir -bootcla ...    phonegap        line 0    BlackBerry Java Problem



It's some sort of strange compiler error and I don't know what to do.  Is there some JDK configuration I'm missing or something like that?


Thank you!!!!



Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-, Z10 (STL100-3)-, Z30 (STA100-5)-, Passport (SQW100-1)-, PlayBook (16GB)-
My Carrier: Verizon

Re: Compiler Error in Eclipse

Try cleaning the project before running the simulator (Project->Clean).


On a side note when you select "Build" Eclipse builds the project but it is not compiled for the BlackBerry. To build for the BlackBerry you... darn, I can't remember. I always used the shortcuts. The "compile for BlackBerry" shortcut is ALT-B.


When you run the simulator it automatically compiles your project for the BlackBerry.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Developer
Posts: 3
Registered: ‎11-17-2009
My Device: Not Specified

Re: Compiler Error in Eclipse


Thanks a lot!  Cleaning and rebuilding with the existing project didn't work, but when I created a new project and copied the sources over and did a clean and rebuild, it worked.  Thanks!!!!!