Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 43
Registered: ‎11-14-2011
My Device: Cure 9300 3G
My Carrier: Vodacom South Africa

Configure simulator to run using a specific JRE?

[ Edited ]

Hello

 

How can I configure a simulator to run using a specifc JRE?

 

Hendré

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Configure simulator to run using a specific JRE?

Not sure I understand the question.

 

Simulators run using a specific level of OS.  If you need a different level of OS, then download a different Simulator.

 

The only relationship between Simulators and JRE is the level used in the JRE used to develop the app.  It must not be a later OS level. 

 

If I have not answered the question, please ask again.

 

Finally, Can you please use a smaller font?

Contributor
Posts: 43
Registered: ‎11-14-2011
My Device: Cure 9300 3G
My Carrier: Vodacom South Africa

Re: Configure simulator to run using a specific JRE?

Hello Peter

 

I use Amazon for hosting. While interactiing with the Amazon website, I was promted to upgrade to the latest version of Java, JRE 7u5. So i did.

 

My signature tool then stopped working. Some API's were signed and some not, stalled waiting for a repsonse from the Code Signing Servers. I then configured eclipse to run using JDK 1.6u32. This resolved my Signature Tool issue.

 

Seeing how sensitive the Signature Tool is to a JRE change, I was wondering if Simulators have a similar sensitivity, thus requireing a specific JRE to run in.

 

Hendré

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Configure simulator to run using a specific JRE?

Sorry, my mistake.  I thought by JRE you meant the OS level specific environment that you download with Eclipse.  Not the Java JRE. 

 

Your question makes more sense now.

 

I might be wrong, but I believe that the Simulators all include their own JVM, If you look in the directory you will see a Jvm.dll, and it is this that runs the Simulator I think.  So in short, because they come with their own JVM, there is no dependency for the Simulators to have Java installed.

 

I have installed Simulators on machines that I don't think had java installed at all, which sort of confirms this. 

Highlighted
Developer
Posts: 40
Registered: ‎09-08-2011
My Device: 8900
My Carrier: AIS

Re: Configure simulator to run using a specific JRE?

We're supposed to stick with the java 1.6 series.

 

As I understand it, BlackBerry use their own compiler to create .COD files anyway.