Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
Contributor
Posts: 21
Registered: ‎04-21-2011
My Device: Developer
My Carrier: ----

Connection Factory Error

  Hi,

 

       I was previously using the Coonector.Open in my application in order to communicate through web services.  But now we are using Connection Factory for the same purpose.

 

      It seems to work fine with the BIS enabled sim but  when run  using wi-fi on device I get  this  error

" Uncaught Exception:Application [name] (id) tnot responding;process terminated"

 

  The response code is 200 as in  the connection is a success but the device terminates the aplication.

 

 I found this while exploring regarding the error.

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800451/800783/Support...

 

  I  am creating the connection in seperate thread all the time.I am clueless as to what is to be done.

 Also I am unable to  run the code that uses Connection  Factory on simulator.Please tell me a way to do this too.

 

Developer
Posts: 541
Registered: ‎05-17-2009
My Device: Not Specified

Re: Connection Factory Error

Could you show the code where you work with the connection? Perhaps you may be blocking the event thread in a way unrelated to the connector?

 

One reason why you may see the code work on the simulator and but get an error on the device is because the device works slower than the simulator. Because everything runs so much faster on the simulator, the message queue might get stressed but never enough to cause a fatal error. This is why testing on various devices can be very helpful.

 

Scott