Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 21
Registered: ‎03-27-2009
My Device: Not Specified

Crash running Storm emulator from Eclipse plugin

When I run the Storm emulator in debug mode from the Eclipse plugin, the app sometimes crashes when I go to File->Exit.  That's fine since I expect the app to exit, but then I can't start a new debug session.  I get an error message in Eclipse saying that "A Blackberry debugging session is already active.  Only one BlackBerry debugging session can be active at one time.".  The only solution seems to be restarting Eclipse, which is very annoying.

 

Is there a way to prevent the crash?  If not, is there a way to set up my environment to run the debugger again without restarting Eclipse?

Highlighted
Developer
Posts: 56
Registered: ‎07-14-2008
My Device: Not Specified

Re: Crash running Storm emulator from Eclipse plugin

I've found it better to kill the debugger from the Debug tab. (which you may have to add to your workspace). 
New Developer
Posts: 4
Registered: ‎04-15-2009
My Device: Not Specified

Re: Crash running Storm emulator from Eclipse plugin

I'm also have this issue.  

However, Skicson, I don't see any option to kill the debugger from my Debug Tab.  I think I've been through all the Eclipse options as well.  If you know how this is possible, would you mind pointing me in the right direction?

Developer
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Crash running Storm emulator from Eclipse plugin

This might be because of the process of fledge that is running in your OS .. You can kill the fledge's process by using the windows task manager ..

 

Cheers.. 

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group
BlackBerry Development Advisor
Posts: 15,809
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Crash running Storm emulator from Eclipse plugin

What BlackBerry Simulator model and BlackBerry handheld software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.  What version of Eclipse are you using?  What OS is running on your PC?  Does it also crash if you use the red X instead of File -> Exit?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Developer
Posts: 21
Registered: ‎03-27-2009
My Device: Not Specified

Re: Crash running Storm emulator from Eclipse plugin

The 9530-JDE is the Simulator model.  The Simulator reports its OS as 4.7.0.75.  I am running Eclipse 3.4.2

M20090211-1700 on Windows Vista Enterprise.  It will crash regardless of whether I use the red X or File->Exit.

Developer
Posts: 21
Registered: ‎03-27-2009
My Device: Not Specified

Re: Crash running Storm emulator from Eclipse plugin

I noticed that the Storm emulator doesn't run fledge.exe and when the crash occurs I don't have a fledge.exe process to terminate.  None of the processes in my Windows task list appear to be the process to cancel to relinquish the resources so that I can run the emulator again.  The emulator works after a restart of Eclipse.
BlackBerry Development Advisor
Posts: 15,809
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Crash running Storm emulator from Eclipse plugin

There is a known issue for the BlackBerry Simulators that when running on 64 bit Vista you need to end task on the BlackBerry Simulator in order to close it.  Our development team is aware of this issue.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Developer
Posts: 21
Registered: ‎03-27-2009
My Device: Not Specified

Re: Crash running Storm emulator from Eclipse plugin

I'm not running 64-bit Vista.

 

And this thread wasn't marked solved.

New Developer
Posts: 4
Registered: ‎06-02-2009
My Device: Not Specified

Re: Crash running Storm emulator from Eclipse plugin

I also have this happen often enough to be a pain. As for the note about not having marked the thread solved, that line is a signature line several people use. Ok, now off to restart eclipse so I can run the emulator again...