Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 455
Registered: ‎03-04-2011
My Device: Paper cup

Debugger doesn't work

Debugger will not work when testing on-device.  Breakpoints don't get hit.


Just built it in JDE 5 and loaded on device.  Attached debugger.  It shows output messages, but does not trip.  Tried restarting JDE, resetting device etc.  Tried 2 different apps.  Nothing.


Has anyone experienced this and solved it?  This happened before when I was using the preprocessor, but now it's just a simple app.




BlackBerry Development Advisor
Posts: 15,882
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Debugger doesn't work

Have you installed a BlackBerry smartphone simulator that has the same OS as your BlackBerry Smartphone?


Note that the version of BlackBerry JDE should also match that of your device.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 140
Registered: ‎02-08-2010
My Device: Torch 9800, Storm 9530, Curve 8330
My Carrier: AT&T, Verizon

Re: Debugger doesn't work

Phone has , only Verizon 9650 simulator I can find is .  I've got that sim installed, and did try the 6.0 JDE also.  It always gives the two pop-up errors when attaching, won't report many variables, and usually doesn't show the subclass of an exception.


A couple of breakpoint incidents were traced to the cause, but other times I don't know why it doesn't work.


For example, it happens if I use the preprocessor, or if the app has a line like this at the top of main():


     if (DeviceInfo.isSimulator()) return;


In that case it won't even break at the start of that line, it just doesn't break anywhere (running on device, not in simulator).  Removing the above line fixed that particular case (breakpoints then worked), and no longer using the preprocessor solved it in another case.