Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 41
Registered: ‎09-26-2008
My Device: Not Specified
Accepted Solution

Dependency problem with new Blackberry Plugin for Eclipse

I've just run into a problem with the new version of the Eclipse JDE Plugin. I have set up my application project so that it uses two other projects as libraries. Both of those projects are on the Java Build Path in the project settings of the application project, and the Eclipse Builder compiles them without errors.

But when I try to run them on the simulator, the application loader throws an Exception, claiming that he couldn't find one of the classes contained in the library projects. Since it's the first class import in the main class, I'm assuming that it couldn't find the entire library.

I tried having the application project import the alx files of the two library project, but nothing changed.

In the old version of the Plugin, there was a project property "Blackberry Project Dependencies" or something like that, which had to be set for the library projects so that rapc.exe and the simulator would find them. That went away, and I was told during Devcon that now it would be sufficient to add the libraries to the class path. Apparently that's not so for me.

Can you give me a hint what's going wrong?
BlackBerry Development Advisor
Posts: 15,886
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Dependency problem with new Blackberry Plugin for Eclipse

Are they library projects marked as active?  Can you check the simulator directory to see if the cod files for your library cod files are there?  The path will look something like this:



Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 41
Registered: ‎09-26-2008
My Device: Not Specified

Re: Dependency problem with new Blackberry Plugin for Eclipse

The problem seemed to be that I imported my projects from the earlier Eclipse Blackberry Plugin version. I have now created a new workspace and new projects, retaining inly the source files, and it works.