Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 15
Registered: ‎10-10-2008
My Device: Not Specified
Accepted Solution

Developer Lab example not working (Connecting to a Network)

Good Morning,

 

I was building the Developer Lab entitled Connecting To A Network (URL) and noticed a problem.

 

When I had MDS running, I could easily use the sample to get to a website like "cnn.com". But when I pointed it to a web page on my pc (http://localhost/MyWeb/Sample.aspx) it said there was not any permission to do that.

 

Is this a setting in the MDS? Or is it something else?

New Developer
Posts: 9
Registered: ‎10-08-2008
My Device: Not Specified

Re: Developer Lab example not working (Connecting to a Network)

Hi!

 

Just a thought - instead of using "localhost", use the IP address of the machine instead. So instead of 

 

http://localhost/MyWeb/Sample.aspx

 

You should try:

 

http://a.b.c.d/MyWeb/Sample.aspx

 

 where "a.b.c.d" is the IP address of the machine.

 

"localhost" may not get resolved correctly - my guess is that if you were running this application on a real BlackBerry device, "localhost" would be resolved to the device itself (because that's what "localhost" means when I type that into a browser on my PC).

 

Cheers,

 

karl

 

Developer
Posts: 15
Registered: ‎10-10-2008
My Device: Not Specified

Re: Developer Lab example not working (Connecting to a Network)

That worked out well. Thank you!