Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 263
Registered: ‎10-27-2010
My Device: 8520

Device performance becomes slow, after installing my application

Hi,

 

   I am developing an application having sending and receiving features....i am using sms demo(in samples of JDE) for sending and receiving...

 

    total size of my application is 600 kb..now the problem is after installing the application in the device..first of all it's working fine with out any problems but after some time it becomes slow..when i restart the device it's fine for some time but again problem occurs...

 

    I debugged my total code but no exception is thrown.....

 

can any body tell me what's the problem....

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Device performance becomes slow, after installing my application

Not enough info here for anybody to give you any specific help.

 

Some possible issues that spring to mind:

 

* creation of excessive garbage, such that GC runs all the time

 

* doing excessive processing in the event thread, which causes the the event queue to back up and make the device appear unresponsive

 

Developer
Posts: 17,019
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Device performance becomes slow, after installing my application

my bet is on the event thread
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Device performance becomes slow, after installing my application

When you say slow, does this apply to all applications on the device, or just your application.

 

Can you describe what happens that makes you think it is slow.  For example, do you click on the menu button and the menu takes a long time to come up?  Does the hour glass show while this is happening? 

Developer
Posts: 263
Registered: ‎10-27-2010
My Device: 8520

Re: Device performance becomes slow, after installing my application

Hi, Thanks for your reply....

 

       here after installing the application both device and my application becomes slow....

 

even if i trying to navigate options or if  i want to make any call from home also becomes slow......

 

again if i restart the device it's fine for some time both the application and device is fine but again the same problem occurs.....

Developer
Posts: 263
Registered: ‎10-27-2010
My Device: 8520

Re: Device performance becomes slow, after installing my application

i have tested the same in 8100 and 8520 in 8100 the hour glass comes and processing for long time and then actions starts...

 

in 8520 after installing my application it takes time for every action in all applications not only in my application...

 

if i remove my applicaiton again it's fine.........

 

in both devices i have updated the OS..

 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Device performance becomes slow, after installing my application

I would recommend that you run the profiler and look at the memory and processor usage of your application.

 

Search the forum for further information on running the profiler.