Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 98
Registered: ‎12-29-2009
My Device: Bold
My Carrier: Rogers

Disconnect between Simulator and Handheld

[ Edited ]

Hi,

 

There appears to be some disconnect between the BB simulator that I am using and my BB handheld.

 

Both are running OS 4.6; both are BB Bolds; and both use the same connection suffix.  However, the simulator is able to download and parse an xml that points to an ad banner image, but the handheld is not.

 

Any ideas on what might be the issue?  Perhaps there are some things I need to look into?

 

Any help would be most appreciated!

 

Cheers.

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Disconnect between Simulator and Handheld

This would likely be your problem:

 

both use the same connection suffix.

 

This almost never works. Can you be more specific about what type of suffix you are using?

 

 

Developer
Posts: 98
Registered: ‎12-29-2009
My Device: Bold
My Carrier: Rogers

Re: Disconnect between Simulator and Handheld

The suffix that connects through WAP2

 

";deviceside=true;ConnectionUID=WAP2 trans"

 

Funny, this methodology has worked for all other xml parsing features in my app--everything from downloading various xml files to posting variables to a server-run PHP script.  

 

For some reason it just doesn't work when parsing through a very specific xml file that contains a url to an ad banner .png file.  So, I'm not too sure it's the connection suffix.

 

Maybe I should display the data that is parsed in an error pop-up.  It might give me some idea as to where things are going wrong?