Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 17
Registered: ‎04-02-2009
My Device: Not Specified

Downloading new SDK's

I keep getting message that my ip address is not from supported country. 

This is real disaster, what does this means? Only some of the country are really supported for developing BB applications? 

Other mobile environments has not that kind limitations. 

Please remove country limitations for downloading new SDK's and emulators ASAP. 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Downloading new SDK's

What country are you in?

New Developer
Posts: 17
Registered: ‎04-02-2009
My Device: Not Specified

Re: Downloading new SDK's

In Serbia, 

is it forbidden to develop BB application from this location? If so I am braking the law.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Downloading new SDK's

I suspect the issue is not the development, but the access to the encryption routines that are included in a BlackBerry.  Let us see if we get a comment from anyone in RIM.

New Developer
Posts: 17
Registered: ‎04-02-2009
My Device: Not Specified

Re: Downloading new SDK's

[ Edited ]

 

The problem is that I cannot update eclipse plugin, as well as install component pack for 6.0.

BlackBerry Development Advisor
Posts: 15,727
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Downloading new SDK's

I'm looking into this and will post an update when I have more information.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 17
Registered: ‎04-02-2009
My Device: Not Specified

Re: Downloading new SDK's

Any news on this?

 

I am able now to download JDE, but cannot download eclipse component pack for 6.0 still. 

There is same message that my ipaddress is on the list of restricted countries?

BlackBerry Development Advisor
Posts: 15,727
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Downloading new SDK's

I don't believe it should be blocked, but have yet to confirm this.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 17
Registered: ‎04-02-2009
My Device: Not Specified

Re: Downloading new SDK's

Here is the error that I am getting in eclipse:

 

 

An error occurred while collecting items to be installed
  session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).
  HTTP Request Not Acceptable: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    HttpClient connection error response code 406.

 

 

 

If I try to download manually from that URL, by browser, I can see this error:

 

 

HTTP Status 406 - User's IP resolved to a country which is in the software's restriction list.

type Status report

message User's IP resolved to a country which is in the software's restriction list.

description The resource identified by this request is only capable of generating responses with characteristics not acceptable according to the request "accept" headers (User's IP resolved to a country which is in the software's restriction list.).

 

 

 

Highlighted
New Developer
Posts: 7
Registered: ‎05-08-2009
My Device: Not Specified

Re: Downloading new SDK's

The same problem Smiley Mad (. But I'm from Belarus.