Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 6
Registered: ‎06-15-2010
My Device: Not Specified

Downloading the plugins to Eclipse

I'm running Ubuntu(Linux) on my computer so I couldn't use the .exe files. I downloaded the Web Development Plugin for Eclipse 1.0 using this link: http://www.blackberry.com/developers/webeclipse. This went fine. Next, I tried to download the JDE plugin from this link: http://www.blackberry.com/go/eclipseUpdate. However, Eclipse said that no repository was found. Is this a Linux issue or is there another link I should have used.

New Contributor
Posts: 6
Registered: ‎06-15-2010
My Device: Not Specified

Re: Downloading the plugins to Eclipse

[ Edited ]

*Update

 

Under "Already Installed", I see 

 

Blackberry Java Plug-in

Blackberry Java SDK

 

I'm still looking for the JDE

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Downloading the plugins to Eclipse

You won't find the "JDE" the BlackBerry Java Plug-in is Eclipse's JDE equivalent. So it seems you have everything you need installed.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Downloading the plugins to Eclipse

Also, the update site for the Java Plug-in is:

 

http://www.blackberry.com/go/eclipseUpdate/3.5/java

 

The update site for widgets and/or web is:

 

http://www.blackberry.com/go/eclipseUpdate/3.5/web

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
New Contributor
Posts: 6
Registered: ‎06-15-2010
My Device: Not Specified

Re: Downloading the plugins to Eclipse

I downloaded the plugin from here http://www.blackberry.com/go/eclipseUpdate/3.5/java. When I try to name my new Blackberry project, I get  

No BlackBerry JRE is installed. Please click "Configure JREs..." link to configure a BlackBerry JRE

 But when I click "Configure JREs", all I see is 

 

java-6-sun-1.6.0.20

 

 

 

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Downloading the plugins to Eclipse

Using the same update site, you should be able to download JREs for each OS version.

 

So you should see 5.0, 4.7, 4.6.1, 4.6 and 4.5. Install at least 5.0 and any other versions you need and let it install. Once restarted, you should be ok.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
New Contributor
Posts: 6
Registered: ‎06-15-2010
My Device: Not Specified

Re: Downloading the plugins to Eclipse

I'm not sure if this matters but it doesn't say JRE. It says Blackberry SDK (and then the versions you mentioned). I installed the plugin as well as the SDK's. Then I restarted but it still doesn't work.

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Downloading the plugins to Eclipse

So you're saying that you cannot create a new BlackBerry project or are you receiving an error message when you try to do something?

 

What are you trying to accomplish?

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
New Contributor
Posts: 6
Registered: ‎06-15-2010
My Device: Not Specified

Re: Downloading the plugins to Eclipse

I'm trying to create a new Blackberry Project.

 

I go to File>New>Project. I select "Blackberry Project". A window shows up prompting me to name the new project. When I type something in, the error at the top says 

 

No BlackBerry JRE is installed. Please click "Configure JREs..." link to configure a BlackBerry JRE

 

 

New Contributor
Posts: 6
Registered: ‎06-15-2010
My Device: Not Specified

Re: Downloading the plugins to Eclipse

Am I forgetting an update site for Eclipse?