Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 22
Registered: ‎05-04-2009
My Device: Bold 9930
My Carrier: Verizon
Accepted Solution

Eclipse JDE Won't Load Anymore

[ Edited ]

I recently installed the latest Eclipse Plugin for BlackBerry OS 7, the release as of October 18th, 2011.  It worked great at first, but the last couple days I have not been able to open it.  It gets hung up on the Eclipse splash screen.  I tried launching eclipsec.exe from the command line and was able to copy this information:

13:43:28,672 TRACE [R] ContextManager starting, bundle version:
13:43:28,756 DEBUG [C] Property change listener is enabled.
13:43:28,784 TRACE [R] ContextManager startingneed update: true
13:43:28,787 TRACE [B] Entering ResourcesBuilder build();kind=9
13:43:28,788 DEBUG [T] Starting Search for CPs
13:43:28,792 TRACE [B] Leaving ResourcesBuilder build()
13:43:28,792 DEBUG [T] CP named BlackBerry Java SDK version 7.0.0 was found at H
13:43:28,848 DEBUG [B] qualifier: 0
13:43:28,852 DEBUG [K] VM: *ADDED* [1318982160325$H:\Program Files (x86)\Java\jr
13:43:28,852 DEBUG [K] VM: *ADDED* [BlackBerry JRE 7.0.0$H:\Eclipse\plugins\net.
13:43:28,873 TRACE [V] Attempting to create VM with name - BlackBerry JRE 7.0.0
13:43:28,885 DEBUG [I] Bundle [net.rim.ejde] is changing state to Started.
Connection timed out: connect
13:43:50,049 DEBUG [B] qualifier: 19


After that, it stops responding and I cannot load Eclipse.  Here's the information in my .metadata\.log file:


!SESSION 2011-11-03 13:43:27.411 -----------------------------------------------
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.resources 2 10035 2011-11-03 13:43:28.244
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.


Has anyone else had this issue? Any ideas?  I've already tried removing and re-downloading/re-installing Eclipse.


Thank you!


Posts: 22
Registered: ‎05-04-2009
My Device: Bold 9930
My Carrier: Verizon

Re: Eclipse JDE Won't Load Anymore

Seems to have been a corrupted workspace. I was using the same one as before, so as soon as I remove it, Eclipse recreated it and launched without issue.