Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
New Developer
Posts: 6
Registered: ‎10-01-2008
My Device: Not Specified

Eclipse Plugin Beta2

[ Edited ]
Does anyone know how to use 4.2.1 Component package with the new beta?
Message Edited by kmorey on 10-26-2008 05:58 PM
Retired
Posts: 76
Registered: ‎07-11-2008
My Device: Z10
My Carrier: SingTel

Re: Eclipse Plugin Beta2

Have you successfully installed the component pack?

 

Once this is installed, you can switch to it by clicking on the Window menu in Eclipse, selecting Preferences, expanding BlackBerry JDE, clicking on Installed Components and selecting version 4.2.1.

Sarim
BlackBerry Development Advisor
www.BlackBerryDeveloper.com
New Developer
Posts: 6
Registered: ‎10-01-2008
My Device: Not Specified

Re: Eclipse Plugin Beta2

The component pack is installed as I was using it with the old eclipse plugin in Europa.

 

When I installed Ganymede and the new eclipse plugin beta2, the only component packs that whow in the Installed Components drop down are 4.3.0 and higher.

BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Eclipse Plugin Beta2

Version 4.2.1 is not currently supported. 

 

The beta 2 release of the BlackBerry JDE Plug-in for Eclipse requires the Eclipse Software Update for the JDE 4.x Component Pack.  It does not support previous release of the BlackBerry JDE Component Pack.  Currently, these releases go back to version 4.3.0.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 16,998
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Eclipse Plugin Beta2

which makes the plugin again unusable for "real" development. 4.2.1 is still de-facto standard for application development.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Developer
Posts: 319
Registered: ‎07-20-2008
My Device: Not Specified

Re: Eclipse Plugin Beta2

Yeah, I have to agree with Simon.  4.2 is still the standard for most of us.

 

New Developer
Posts: 15
Registered: ‎10-06-2008
My Device: Not Specified

Re: Eclipse Plugin Beta2

Just to be clear (as I'm very new to BB development), it sounds like it is not possible to use the BB Eclipse plugin to create an application that will work on a BB 4.2 device?

 

I have a 1.5 year old BB Pearl (8100) with v4.2.0.42, and no newer version of the OS is supported.  That would make it impossible to write an application for my device using Eclipse...

Developer
Developer
Posts: 319
Registered: ‎07-20-2008
My Device: Not Specified

Re: Eclipse Plugin Beta2

You should be OK as long as you don't use any of the APIs that showed up in 4.3.  You should thoroughly test in a 4.2 simulator though to make sure.

 

Developer
Posts: 213
Registered: ‎07-18-2008
My Device: Not Specified

Re: Eclipse Plugin Beta2

I installed this plugin . Previously i was using Eclipse Europa 3.3.1, but now the problem is as follows:

 

Window ->Preferences -> BlackBerry JDE -> Installed Components

 

The "Browse" button beside "Choose Installed Components"  does not appear anymore which was not the case with Eclipse Europa as I can select components i installed in different directory. Now, how do I switch between different components ???

 

thanks

 

yosoh

--------------------------------------------------
problemSolved() ? kudosPlease():kudosPlease();
New Developer
Posts: 15
Registered: ‎10-06-2008
My Device: Not Specified

Re: Eclipse Plugin Beta2

I have a "hello world" application, so I'm sure I'm not using any 4.3 APIs.  It runs fine in the simulator (the 4.3 simulator), but when I try to load it using the desktop manager it gives me an error message - "A fatal error occurred while updating your device's software.  Please try again.".

 

The loader's log file has this very helpful error in it:

[10:05:39:734] [JavaProgrammer] [0x00001bc4] [JavaProgrammer.cpp:788] Loading module "C:\Dave\Projects\BlackBerryTest\BBTest.cod"

[10:05:39:750] [JavaProgrammer] [0x00001bc4] [JavaProgrammer.cpp:1231] JavaLoader operation failed (10): "Unspecified error encountered [J:0x0000000A]"

 

I assumed this had something to do with the wrong version of the API (I read something to that effect in another thread), but maybe that's not the real cause...