Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 2
Registered: ‎04-20-2010
My Device: BB Storm
My Carrier: Optus

Eclipse Plugin installs but does not show up - VERY FRUSTRATED!!!

I have spent the last 3 days trying to get Eclipse to install on my machine with no luck.

 

I have XP Service Pack 2

 

I have tried a whole raft of options but all result in the same outcome. I have Eclipse which says the plugin is installed BUT it does offer me any of the Blackberry options.

 

See the following screen shots

 

a) shows the "Install New Software" screen with the plugin displaying as installed

b) shows the "Plugin details screen" ONLY showing the SDK is installed WHEN in fact the Plugin is also installed

c) the contents of the Eclipse plugins folder

d) the "New Other" wizard which demonstrates that the plugin is not installed

 

1726i470742E955924274

 

1727iEDC383CEBE5633A7

 

1728i759B1D9468E880B0

 

1729i09E7129B607351ED

 

The options I have tried are:

 

1) Download full installer from: http://na.blackberry.com/eng/developers/javaappdev/devtools.jsp

 

Also I have tried

 

2a) Install a vanilla version of Eclipse Galileo 3.5.2

b) Go to "install new software" and choose "http://www.blackberry.com/go/eclipseUpdate/3.5/java"

c) I have installed the Plugins, separately and together but always the same result. The install says it is successful but the features are not available

 

I did have an older version of Eclipse running on the machine in the past but I deleted this prior to trying to get this to work.

 

please any help would be greatly appreciated as it is doing my head in?

Developer
Posts: 304
Registered: ‎04-30-2008
My Device: Not Specified

Re: Eclipse Plugin installs but does not show up - VERY FRUSTRATED!!!

Can't see your images, they probably have to be approved by a mod which can take a bit of time.

 

I too had some problems getting everything installed and configured properly.  I think the first time I tried it was similar to you in that it didn't showin the plugin anywhere.  I didn't document all the steps I took so I can't tell you exactly what to do but I can tell you roughly what I did and what I had problems with.

 

 

-first, make sure you have the exact release of Java cited in the requirements (I think 6 release 16 but I could be wrong) and pathed

-When I got it working I believe I installed it over top of an older version of Eclipse that worked with 1.0 plugin and the installer upgraded my Eclipse.

-As I said, I think the first time I tried this the plugin didn't show up so I think I re-installed it from the full installer file and possibly also from the update site.

-Follow the config steps

 

I don't think it took much more than that to get my plugin to show its face although I did have further problems with upgrading apps and having my code signing keys stop functioning.

 

good luck.

 

T

New Developer
Posts: 9
Registered: ‎03-04-2009
My Device: Not Specified

Re: Eclipse Plugin installs but does not show up - VERY FRUSTRATED!!!

I too have experienced this problem, and the associated frustration, and confirm that upgrading to the latest JVM fixed the problem.

 

In my case upgrading to 1.6.0_26.