Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
Contributor
Posts: 32
Registered: ‎08-13-2012
My Device: 9800
My Carrier: Rogers
Accepted Solution

Eclipse Strange State

Somehow I have lost a lot of functionality in Eclipse related to Blackberry. First you will notice in the screen below that below "Run as" and "Debug" there should be a setting for "Blackberry". This would be normally where I could "Launch on Device".  Also, you will notice that the blackberry icons are missing near the top of the screen. So things like 'Debug as", "Clean Simulator" and "Run as" icons are all missing.

 

I have set the perspective to "Blackberry". I'm at a loss why this feature is missing. The only things I could see a conflict right now was the I installed the 'egit' plugin recently.

 

Any suggestions would be greatly appreciated.

 

Thanks!

 

strange mode.png 

Developer
Posts: 729
Registered: ‎05-04-2011
My Device: 9700

Re: Eclipse Strange State

Try: Window menu -> Reset Prespective.

E.

Contributor
Posts: 32
Registered: ‎08-13-2012
My Device: 9800
My Carrier: Rogers

Re: Eclipse Strange State

I still do not have the text 'Blackberry' in the context menu under 'Debug as'. The good news is that I am just using the Menu on the top under 'Blackberry' and i have all options available there. Strange stuff going on but at least I have a workaround.

 

Thank you for your kind reply