Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 35
Registered: ‎09-11-2008
My Device: Not Specified

Error Installing BlackBerry plugin for Eclipse

I am having the same exact problem. I am running Eclipse Ganymede (version 3.4.1) on Windows Vista and am unable to install the plugin. I go to Help-->Software Updates-->Add Site. I select "Archive", and then I select the zip file in the Repository Archive window and click on Open. I then click on OK in the Add Site window, and get an error window with the following message:

 

"Loading

jar:file:C:\Users\user1\Desktop\eJDE-Beta2_With_4_5.zip!/

has encountered a problem.

 

No repository found at

jar:file:C:\Users\user1\Desktop\eJDE-Beta2_With_4_5.zip!/

"

 

When I click on "details" from the Problem Occurred window, I get the following message:

 

"No repository found at jar:file:C:\Users\user1\Desktop\eJDE-Beta2_With_4_5.zip!/

Error reading update site jar:file:C:\Users\user1\Desktop\eJDE-Beta2_With_4_5.zip!/.

error opening zip file"

 

I also tried opening the zip file manually both in WinXP and Vista;

On XP I get: 

"Cannot open file: it does not appear to be a valid archive. If you downloaded this file, try downloading the file again"

 

On Vista I get:

"Windows cannot open the folder. The Compressed (zipped Folder 'C:\Users\User1\Desktop\eJDE-Beta2_With_4_5.zip!' is invalid"

 

The file is 179 MB and I have downloaded it several times from BlackBerry's website: http://na.blackberry.com/eng/developers/javaappdev/javaeclipseplug.jsp

 

This looks to be a problem with the file itself as I was able to open the eJDE-4.6 and eJDE4.7 Component zip files manually with no problem. Is Blackberry even aware that this file does not work? Does anyone have a WORKING plugin file I can get a hold of?  Thanks.

Developer
Developer
Posts: 319
Registered: ‎07-20-2008
My Device: Not Specified

Re: Error Installing BlackBerry plugin for Eclipse

Yep, Same problem here.
BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Error Installing BlackBerry plugin for Eclipse

From what country are you downloading the file from?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 35
Registered: ‎09-11-2008
My Device: Not Specified

Re: Error Installing BlackBerry plugin for Eclipse

US
Developer
Developer
Posts: 319
Registered: ‎07-20-2008
My Device: Not Specified

Re: Error Installing BlackBerry plugin for Eclipse

US for me too.

 

Highlighted
BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Error Installing BlackBerry plugin for Eclipse

Thank you for the location information.  This issue is under investigation.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker