Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 5
Registered: ‎07-29-2011
My Device: 8520
My Carrier: Project Manager
Accepted Solution

Error in BlackBerry_App_Descriptor.xml

Hi Experts,

 

I had my application running perfectly. But I don't know what happened. I am getting now the following error in BlackBerry_App_Descriptor.xml file:

 

InvalidRegex: Pattern value '([a-zA-Z_]{1,63}[\s-a-zA-Z_0-9.]{0,63}[;]?)*' is not a valid regular expression. The reported error was: ''-' is an invalid character range. Write '\-'.' at column '{2}'. BlackBerry_App_Descriptor.xml

 

Do you have any idea why?

 

BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Error in BlackBerry_App_Descriptor.xml

Check some of the fields of the BlackBerry App Descriptor that have restricted values (like the version) for invalid characters (focus on -).

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 102
Registered: ‎07-26-2011
My Device: Not a blackberry user
My Carrier: None

Re: Error in BlackBerry_App_Descriptor.xml

Greetings.

Since the sole issue is on the App Descriptor (which is created by Eclipse), move the .java files to other path and delete the project from Eclipse (and your workspace) and then recreate the project and import the.java files.

The previous will give to Eclipse the chance of creating the App Descriptor again.

I hope this be helpful. It worked for me the last time I faced the same issue.

Let me know if this was helpful or if you have a solution.

Johan Guzmán - In case my answer pleased you, give a press to the LIKE button, please!! Mark this post as solution if it solved your problem.
New Contributor
Posts: 5
Registered: ‎07-29-2011
My Device: 8520
My Carrier: Project Manager

Re: Error in BlackBerry_App_Descriptor.xml

I solved it. I deleted the BlackBerry_App_Descriptor.xml and then it got created again.

New Developer
Posts: 15
Registered: ‎10-22-2008
My Device: Not Specified

Re: Error in BlackBerry_App_Descriptor.xml

There seems no doubt that some bizarre problem has been introduced. I recently installed the latest version of the plug-in using BlackBerry_JDE_PluginFull_1.3.0.201102031007-19.exe. Not only do two projects that worked just fine before the upgrade exhibit this problem, but when I create a new, empty Blackberry project it has this error as soon as it is created. I have tried everything I can think of to get rid of this. Even more bizarrely, at one point when I made some change to the properties of the new project, one of my older projects started working ok. But the next time I opened the workspace they were all in this state again. I would suggest that the problem has something to do with the way one of the builders is interpreting the contents of the application descriptor file, but I haven't been able to come up with an effective workaround yet.

Developer
Posts: 102
Registered: ‎07-26-2011
My Device: Not a blackberry user
My Carrier: None

Re: Error in BlackBerry_App_Descriptor.xml

As I told (kind of).

Good to know you could solve it. Good luck at all.

Let me know if this was helpful or if you have a solution.

Johan Guzmán - In case my answer pleased you, give a press to the LIKE button, please!! Mark this post as solution if it solved your problem.
New Developer
Posts: 15
Registered: ‎10-22-2008
My Device: Not Specified

Re: Error in BlackBerry_App_Descriptor.xml

John, that's not doing it for me. I delete the application descriptor file from the project, but as soon as a do a Clean or a Build it gets re-created - with the same error. Maybe there's something about the sequence in which you're doing things?

In my experience, some of these unexplainable behaviours have to do with Windows 7 (especially 64-bit) and security. But I can't see how that would apply in this case.
Developer
Posts: 102
Registered: ‎07-26-2011
My Device: Not a blackberry user
My Carrier: None

Re: Error in BlackBerry_App_Descriptor.xml

You have a pretty weird issue my rsudama friend. And I have no workaround for it. Sorry.

Let me know if this was helpful or if you have a solution.

Johan Guzmán - In case my answer pleased you, give a press to the LIKE button, please!! Mark this post as solution if it solved your problem.
BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Error in BlackBerry_App_Descriptor.xml


rsudama wrote:
John, that's not doing it for me. I delete the application descriptor file from the project, but as soon as a do a Clean or a Build it gets re-created - with the same error. Maybe there's something about the sequence in which you're doing things?

In my experience, some of these unexplainable behaviours have to do with Windows 7 (especially 64-bit) and security. But I can't see how that would apply in this case.

Please log this issue in Issue Tracker and attach a copy of your BlackBerry_App_Descriptor.xml file.

 

Issue Tracker

https://www.blackberry.com/jira/secure/Dashboard.jspa

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 15
Registered: ‎10-22-2008
My Device: Not Specified

Re: Error in BlackBerry_App_Descriptor.xml

Ok, I reported this, and have been informed that there was a previous report under TOOLS-280. Basically, the error results from the use of Java 1.7. I've reverted my installation to Java 1.6 (32-bit) and things seem to be working ok again. I wish someone would just say this.