Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Retired
Posts: 179
Registered: ‎07-14-2008
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

Thank you everyone for your patience with this issue.  We have uploaded the content again in our content distribution system which has resolved the issue for the people who have reported it directly to me already. 

 

Please try downloading the software again and let us know if you experience any additional issues.

 

Thanks,

 

 

Mike Kirkup
Director, Developer Relations
Highlighted
New Developer
Posts: 2
Registered: ‎10-30-2008
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

Worked great for me.  Checksum = 7c2e74a243f45b6c66b5ba4056699a06
New Developer
Posts: 4
Registered: ‎10-23-2008
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

It worked finally with this new zip file. Thanks for the fix.

 

I noticed there is an installation instruction available on the website. And interestingly, it's suggested not to unzip the file but use the archive (.zip) when adding a site in Eclipse. I guess the culprit could be the original zip file got corrupt on some PCs like mine during the unzip process.

Developer
Posts: 22
Registered: ‎10-30-2008
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

For me too Smiley Very Happy

 

[165]$ md5sum ~/Desktop/eJDE-Beta2_With_4_5.zip
7c2e74a243f45b6c66b5ba4056699a06 */cygdrive/c/Documents and Settings/hpedroza/Desktop/eJDE-Beta2_With_4_5.zip

[166]$ unzip -l ~/Desktop/eJDE-Beta2_With_4_5.zip
Archive:  /cygdrive/c/Documents and Settings/hpedroza/Desktop/eJDE-Beta2_With_4_5.zip
  Length     Date   Time    Name
 --------    ----   ----    ----
    38889  10-02-08 23:47   features/net.rim.EclipseJDE_1.0.0.50.jar
    38675  10-02-08 01:24   features/net.rim.eide.feature.componentpack4.5.0_4.5.0.14.jar
        0  10-17-08 10:57   features/
  1793471  10-02-08 23:49   plugins/net.rim.eide.bootstrapper_1.0.0.50.jar
184141608  10-02-08 01:26   plugins/net.rim.eide.componentpack4.5.0_4.5.0.14.jar
   121870  10-02-08 23:47   plugins/net.rim.eide.doc_1.0.0.50.jar
   524997  10-02-08 23:49   plugins/net.rim.eide.preprocessing.hook_1.0.0.50.jar
  1598356  10-02-08 23:49   plugins/net.rim.eide_1.0.0.50.jar
        0  10-17-08 10:57   plugins/
      505  10-15-08 10:46   site.xml
 --------                   -------
188258371                   10 files

Developer
Posts: 141
Registered: ‎02-27-2009
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

This is not fixed.

1) Using the Software Updates utility in Eclipse, trying to install the
BlackBerry JDE Plug-in for Eclipse version 1.0.0.50, I got

 

An error occurred while collecting items to be installed
  Error closing the output stream for net.rim.EclipseJDE/org.eclipse.update.feature/1.0.0.50 on repository file:/F:/Java/eclipse/.
  Error unzipping C:\DOCUME~1\Paul\LOCALS~1\Temp\net.rim.EclipseJDE_1.0.0.508367312597811891523.jar: Invalid zip file format
  Problems downloading artifact: osgi.bundle,net.rim.eide,1.0.0.50.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented

    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Problems downloading artifact: osgi.bundle,net.rim.eide.doc,1.0.0.50.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented

    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Problems downloading artifact: osgi.bundle,net.rim.eide.preprocessing.hook,1.0.0.50.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...

    Unconnected sockets not implemented

2) I downloaded the zip file containing the plugin and all of the components (500+ MB).  WinZip said this file was corrupt.

 

3) I downloaded the plugin alone (180 MB) and again WinZip said the file is corrupt.

 

4) I tried to use the  Software Updates utility in Eclipse with one of those zp files and got an error saying there was no repository found at the file path.

 

 

Come on BlackBerry - how hard is it to put a valid zip file on a server - I do it all the time and no one has a problem downloading the file.  How many months (or years) will it take you to do this simple task correctly?

 

New Developer
Posts: 1
Registered: ‎03-01-2009
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

Failing update through Eclipse v3.4 w/ jre 1.6 from:

http://www.blackberry.com/go/eclipseUpdate

Nor can I download any other zip directly for 4.7, 4.6 etc:: "Contact Webmaster""

 

Error msg from Eclispe:

 

An error occurred while collecting items to be installed Error closing the output stream for net.rim.eide.componentpack4.3.0/osgi.bundle/4.3.0.13 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.componentpack4.3.0_4.3.0.135008.jar: Invalid zip file format Error closing the output stream for net.rim.eide.componentpack4.6.0/osgi.bundle/4.6.0.16 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.componentpack4.6.0_4.6.0.165010.jar: Invalid zip file format Error closing the output stream for net.rim.eide.componentpack4.6.1/osgi.bundle/4.6.1.23 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.componentpack4.6.1_4.6.1.235009.jar: Invalid zip file format Error closing the output stream for net.rim.eide.componentpack4.7.0/osgi.bundle/4.7.0.41 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.componentpack4.7.0_4.7.0.415011.jar: Invalid zip file format Error closing the output stream for net.rim.eide.feature.componentpack4.3.0/org.eclipse.update.feature/4.3.0.13 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.feature.componentpack4.3.0_4.3.0.135012.jar: Invalid zip file format Error closing the output stream for net.rim.eide.feature.componentpack4.6.0/org.eclipse.update.feature/4.6.0.16 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.feature.componentpack4.6.0_4.6.0.165013.jar: Invalid zip file format Error closing the output stream for net.rim.eide.feature.componentpack4.6.1/org.eclipse.update.feature/4.6.1.23 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.feature.componentpack4.6.1_4.6.1.235014.jar: Invalid zip file format Error closing the output stream for net.rim.eide.feature.componentpack4.7.0/org.eclipse.update.feature/4.7.0.41 on repository file:/C:/XFER/EclipseDeployments/eclipse3.4.1_BB4.5Beta/. Error unzipping C:\Users\Desiree\AppData\Local\Temp\net.rim.eide.feature.componentpack4.7.0_4.7.0.415015.jar: Invalid zip file format

Developer
Posts: 141
Registered: ‎02-27-2009
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

I should follow up, by saying that yesterday afternoon (Sat), I was able to download the 2 files - eJDE-4_7_Component.zip and eJDE-Beta2_With_4_5.zip, and they both open in WinZip (thus they are valid zip files). I also verified that I could extract the contents of the zip files, so they are valid zips.

 

So what is the deal?  One minute I get corrupt files, then valid ones, then someone else gets corrupted ones again.  RIM - This must be a problem on your servers.

 

New Developer
Posts: 1
Registered: ‎03-09-2009
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

I am having the same issue while trying to install the JDE via Eclipse update site feature.
BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Error installing Blackberry plug-in for Eclipse


PeregrineFalcon wrote:
I am having the same issue while trying to install the JDE via Eclipse update site feature.

There are a few issues in this thread.  Can you clarify what one you are having?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 1
Registered: ‎03-24-2009
My Device: Not Specified

Re: Error installing Blackberry plug-in for Eclipse

[ Edited ]

We are having the same issue as DesireePrincess. Namely, installing the blacberry plugin via the eclipse update site fails with an error message indicating 'invalid zip file'

 

Here is the full message:

 

An error occurred while collecting items to be installed
  Error closing the output stream for net.rim.EclipseJDE/org.eclipse.update.feature/1.0.0.67 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.EclipseJDE_1.0.0.677048148882487926843.jar: Invalid zip file format
  Problems downloading artifact: osgi.bundle,net.rim.eide,1.0.0.67.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Problems downloading artifact: osgi.bundle,net.rim.eide.bootstrapper,1.0.0.67.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Error closing the output stream for net.rim.eide.componentpack4.3.0/osgi.bundle/4.3.0.16 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.3.0_4.3.0.163813174869528176805.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.componentpack4.5.0/osgi.bundle/4.5.0.16 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.5.0_4.5.0.168350359366345089070.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.componentpack4.6.0/osgi.bundle/4.6.0.19 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.6.0_4.6.0.196040200441185733513.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.componentpack4.6.1/osgi.bundle/4.6.1.27 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.6.1_4.6.1.277242227400273090435.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.componentpack4.7.0/osgi.bundle/4.7.0.46 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.7.0_4.7.0.467467473830284076619.jar: Invalid zip file format
  Problems downloading artifact: osgi.bundle,net.rim.eide.doc,1.0.0.67.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Error closing the output stream for net.rim.eide.feature.componentpack4.3.0/org.eclipse.update.feature/4.3.0.16 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.3.0_4.3.0.169073623197643742544.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.feature.componentpack4.5.0/org.eclipse.update.feature/4.5.0.16 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.5.0_4.5.0.161133621082528384575.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.feature.componentpack4.6.0/org.eclipse.update.feature/4.6.0.19 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.6.0_4.6.0.194479082484428997266.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.feature.componentpack4.An error occurred while collecting items to be installed
  Error closing the output stream for
  net.rim.EclipseJDE/org.eclipse.update.feature/1.0.0.67
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.EclipseJDE_1.0.0.677048148882487926843.jar:
  Invalid zip file format Problems downloading artifact:
  osgi.bundle,net.rim.eide,1.0.0.67.
    Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Problems downloading artifact:
  osgi.bundle,net.rim.eide.bootstrapper,1.0.0.67.
    Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
.1.27 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.6.1_4.6.1.271173612590966017158.jar: Invalid zip file format
  Error closing the output stream for net.rim.eide.feature.componentpack4.7.0/org.eclipse.update.feature/4.7.0.46 on repository file:/C:/eclipse/.
  Error unzipping C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.7.0_4.7.0.468916311016251510684.jar: Invalid zip file format
  Problems downloading artifact: osgi.bundle,net.rim.eide.preprocessing.hook,1.0.0.67.
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
    Exception connecting to https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Error closing the output stream for
  net.rim.eide.componentpack4.3.0/osgi.bundle/4.3.0.16
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.3.0_4.3.0.163813174869528176805.jar:
  Invalid zip file format Error closing the output stream
  for net.rim.eide.componentpack4.5.0/osgi.bundle/4.5.0.16
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.5.0_4.5.0.168350359366345089070.jar:
  Invalid zip file format Error closing the output stream
  for net.rim.eide.componentpack4.6.0/osgi.bundle/4.6.0.19
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.6.0_4.6.0.196040200441185733513.jar:
  Invalid zip file format Error closing the output stream
  for net.rim.eide.componentpack4.6.1/osgi.bundle/4.6.1.27
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.6.1_4.6.1.277242227400273090435.jar:
  Invalid zip file format Error closing the output stream
  for net.rim.eide.componentpack4.7.0/osgi.bundle/4.7.0.46
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.componentpack4.7.0_4.7.0.467467473830284076619.jar:
  Invalid zip file format Problems downloading artifact:
  osgi.bundle,net.rim.eide.doc,1.0.0.67.
    Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented
  Error closing the output stream for
  net.rim.eide.feature.componentpack4.3.0/org.eclipse.update.feature/4.3.0.16
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.3.0_4.3.0.169073623197643742544.jar:
  Invalid zip file format Error closing the output stream for
  net.rim.eide.feature.componentpack4.5.0/org.eclipse.update.feature/4.5.0.16
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.5.0_4.5.0.161133621082528384575.jar:
  Invalid zip file format Error closing the output stream for
  net.rim.eide.feature.componentpack4.6.0/org.eclipse.update.feature/4.6.0.19
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.6.0_4.6.0.194479082484428997266.jar:
  Invalid zip file format Error closing the output stream for
  net.rim.eide.feature.componentpack4.6.1/org.eclipse.update.feature/4.6.1.27
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.6.1_4.6.1.271173612590966017158.jar:
  Invalid zip file format Error closing the output stream for
  net.rim.eide.feature.componentpack4.7.0/org.eclipse.update.feature/4.7.0.46
  on repository file:/C:/eclipse/.  Error unzipping
  C:\DOCUME~1\tysonl\LOCALS~1\Temp\net.rim.eide.feature.componentpack4.7.0_4.7.0.468916311016251510684.jar:
  Invalid zip file format Problems downloading artifact:
  osgi.bundle,net.rim.eide.preprocessing.hook,1.0.0.67.
 
    Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented Exception connecting to
    https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA...
    Unconnected sockets not implemented

Message Edited by ljtyson on 03-24-2009 03:13 PM