Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 7
Registered: ‎08-04-2008
My Device: Not Specified

Exception thrown in a midlet constructor



I have a BlackBerry 8800 with firmware (Platform Prosumer from Vodafone.
It wasn't bound with vodafone, therefore it is now running with an O2-simcard and the BlackBerry-Option from O2: Surfing, http, ftp, everything working fine.


I'm developing midlet-apllications with JDE 4.3.0.
First all midlets working fine, but now i get the following error on start every of my midlets:
Uncaught exception: Exception thrown in a midlet constructor


The error occure only on the device, not on the simulator.


Any suggestions?

The following things i already tried or wish to try but don't know how:


-erasing und reinstall with javaloader.exe has no effect.
-The hint from the engl. BB-forum: "erase all application data" in DesktopManager i couldn't try, because this possibility is not available anymore in the actual version

4.5 (i couldn't find it). There was also no information about the version which has this possibility.
-With the next hint: "firmware-Update" i also have a problem: strangely there is no firmware available for the 8800 at the BlackBerry-Homepage.
Can I use every a firmware from any vendor?
After ordering the BlackBerry-Option from O2 i get the browser on the device. Will I loose this after firmware-update?



BlackBerry Development Advisor
Posts: 15,882
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Exception thrown in a midlet constructor

Applications built in version 4.3.0 of the BlackBerry JDE are not compatible with BlackBerry handheld software version 4.2.1.  Please see the link below for more information.


What Is - Appropriate version of the BlackBerry JDE
Article Number: DB-00537


Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
New Developer
Posts: 7
Registered: ‎08-04-2008
My Device: Not Specified

Re: Exception thrown in a midlet constructor

[ Edited ]

Thanks for information.

I tried JDE 4.2.1 and still get the error.


I updated firmware, this solve the problem!

Message Edited by cstarling on 08-13-2008 09:02 AM
Posts: 26
Registered: ‎07-23-2008
My Device: Not Specified

Re: Exception thrown in a midlet constructor

I've seen this exception thrown by a UiApplication. This happens because I was still passing "-midlet" as an argument to rapc. I'm posting this here because I'm sure a few people out there using ant and netbeans will run into it when migrating an existing MIDlet to a UiApplication.
New Member
Posts: 1
Registered: ‎06-25-2013
My Device: Curve 8520
My Carrier: MTN

Re: Exception thrown in a midlet constructor

i have to say if t wasnt this post which i cam accross after i have been stucked for  like 5 hours i would still be confused as hell infront of this computer. thank you for such post *clapping*