Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
Contributor
Posts: 16
Registered: ‎02-23-2010
My Device: bold 9000
My Carrier: orange
Accepted Solution

File is not a valid java cod

Hi,

I am using eclipse 1.0.2  bb java plugin 1.1.1

when loading my application and also some of the bb samples using javaloader I am getting

the error message file is not a java cod file

the output file name is the same as the main class

thanks

 

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: File is not a valid java cod

I'm not sure which version of Eclipse you meant but you need Eclipse 3.5 to use BB Java Plugin 1.1. Also, have you generated an ALX file (it may not be necessary but maybe you can use it with the desktop manager instead).

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Developer
Posts: 141
Registered: ‎02-10-2010
My Device: 9500
My Carrier: Airtel

Re: File is not a valid java cod

Contributor
Posts: 16
Registered: ‎02-23-2010
My Device: bold 9000
My Carrier: orange

thRe: File is not a valid java cod

Thanks for the quick replay

I am using eclipse 3.5.0

the smartphone v4.6.0.304 so maybe this is the problem the BB java sdk is 5.0.0

 

Zahi

 

 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: thRe: File is not a valid java cod

Just to confirm, the files you are attempting to load do end with ".cod"?

Contributor
Posts: 16
Registered: ‎02-23-2010
My Device: bold 9000
My Carrier: orange

Re: thRe: File is not a valid java cod

yes

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: thRe: File is not a valid java cod

Sorry should have spotted this:

 

"the smartphone v4.6.0.304 so maybe this is the problem the BB java sdk is 5.0.0"

 

Correct, develop using 4.6 for a 4.6 (or later) phone.

Contributor
Posts: 16
Registered: ‎02-23-2010
My Device: bold 9000
My Carrier: orange

Re: thRe: File is not a valid java cod

Thanks

Problem solved

 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: thRe: File is not a valid java cod

Can you mark the Thread as solved please?