Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Getting HTTP 406 error in BlackBerry while Connecting using SIM Card

OK, looks like you will have to get the Server folks to tell you what is wrong with the request. 

New Member
Posts: 1
Registered: ‎06-13-2013
My Device: Not specified
My Carrier: Not specified

Re: Getting HTTP 406 error in BlackBerry while Connecting using SIM Card

The server is returning a 200. Some gateway is getting involved and changing it to a 406.

Highlighted
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Getting HTTP 406 error in BlackBerry while Connecting using SIM Card

Sounds strange. 

 

I think you have 4 possible  tracks to chase this, and this is the order I would try them

 

a) Possibly the Gateway does not like what your Server is trying to give back on the request.  So change the response to something simple, perhaps a simple web page, and see if the request gets through then.

b) Possibly there is something else wrong with the request, so change the URL you are using to pick up something random, like a Google page, and see if you still get the 406.

c) Printout the headers in the response (at the BlackBerry) to see if there is any additional information in them.

d) Contact BBDY and try to get them to explain why the BIS-B gateway is returning a 406 to your request.

 

Hope you have enough information to continue on these - if not just ask.