Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 8
Registered: ‎06-16-2011
My Device: Blackberry Q10
Accepted Solution

Having issues setting up Java Enviroments *Noob Help*

Yes I'm having issues installing all of the enviroments for just trying to learn Java! Smiley Sad

I am new to Java development and Blackberry development and I just want to make sure I'm setting up everything correctly.

 

I'm running Windows 7 Home Premium (64-bit)

And so far I've installed:

 

  • Java SDK (6 update 26)
  • Blackberry JDE 6.0.0
  • Blackberry JDE Components 4.7.0
  • Blackberry JDE Eclipse Plugin 1.3
  • Visual Studio Express 2010

 

I'm trying to follow the Writing your First Application.pdf

and right as I get to Page 7 -- "Configuring your new BB Project" it says on Step 4 to select "Installed Components"<<< Nowhere in my version of Eclipse do I see this (or some of the other options for that matter).

 

I thought maybe I didn't install things in the proper order or something so I went back and reinstalled everything in the order the tutorials describe--still nothing +__+

 

I tried opening "Blackberry JDE" by itself and it gives me this error: "Windows cannot find 'javaw'. Make sure you typed it correctly, and then try again."  and then it just closes out, even though I never typed anything.

 

I'm not sure what the issues are..any help would be appreciated, I just want to start learning Java because I have a few cool app ideas floating around.  Please ask if you need more info!

 

Thanks!

Developer
Posts: 17,025
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Having issues setting up Java Enviroments *Noob Help*

welcome to the support forums.

if windows cannot find javaw you have missed the step where you add its path to the PATH variable.
http://www.java.com/en/download/help/path.xml
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Contributor
Posts: 8
Registered: ‎06-16-2011
My Device: Blackberry Q10

Re: Having issues setting up Java Enviroments *Noob Help*

Thank you, this solved my "javaw" issue, but I'm still having the issue regarding the "installed components" setup.

 

I've now moved onto the "User Interface" tutorial and it's popping up an issue that I'm assuming involves the original setup.  It won't locate the .png files needed for the references.

 

Where are all the files stored for the tutorials!?  I've been trying to locate them all morning! Smiley Sad

New Contributor
Posts: 8
Registered: ‎06-16-2011
My Device: Blackberry Q10

Re: Having issues setting up Java Enviroments *Noob Help*

[ Edited ]

I just went to google and downloaded new .png files for the flags, not really the answer, but an easy work around, so I could get back to business.

 

Also, to fix the issue I was having with finding where to select the "Installed components"

I found that this is (in the Blackberry Java Plugin 1.3) now located under:

Project

           >>Properties

                        >>JavaDoc Location

 

So everyone knows for future reference!

 

Thanks for the help and the welcome! Smiley Happy