Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Developer
Posts: 3
Registered: ‎11-23-2009
My Device: Not Specified

How to add MapQuest library

I've downloaded the MapQuest java library, and added it to my BlackBerry project as a "referenced library".  I can compile just fine, and get "intellisense" when I edit code using the MQ library.


However, when I try and run I get a build error "Description Resource Path Location Type
Error!: Error: preverifier failed: C:\Program Files\eclipse\plugins\net.rim.eide.componentpack5.0.0_5.0.0.7\components\bin\preverify.exe ... GeoAppt  line 0 BlackBerry Java Problem" basically stating there is a "preverify" problem.


Perhaps I've added the library the wrong way. How can I get around this error?


I am using Eclipse 3.4.2, and have the Rim component pack 5.0.0_5.0.07 with the JDE plug-in for Eclipse...

Currently running Windows XP SP3 on a 32bit machine.


Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-, Z10 (STL100-3)-, Z30 (STA100-5)-, Passport (SQW100-1)-, PlayBook (16GB)-
My Carrier: Verizon

Re: How to add MapQuest library

Unfortunately from what I checked, the library is written for a desktop application. It might be possible to put a post up on MapQuest's forums asking if they can make a modified version for BlackBerry but it would probably be a good amount of time before they get back to you with a finished library, and that's if they even do it.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Posts: 103
Registered: ‎12-12-2011
My Device: Developer
My Carrier: Robosoft

Re: How to add MapQuest library

Hi, can you please tell me where is the MapQuest library for BlackBerry available for download? Thanks in advance.

Posts: 17,025
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to add MapQuest library

there is none, as you would see if you read the post before yours.
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter