Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 2
Registered: ‎03-10-2013
My Device: Bold 9000
My Carrier: 841644517966
Accepted Solution

How to install 'net.rim.device.api.command.Command'?

Hi,

 

Recently I install IMO instant messenger in my device (Bold 9000 - OS 5.0) but there's an error: Error starting imo: Class 'net.rim.device.api.command.Command' not found. The same happen when I install Wordpress. I couldn't find any information about how to fix this problem. 

 

Please help me with this! 

 

Thank you so much!

 

All the best,

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: How to install 'net.rim.device.api.command.Command'?

This is because the versions you have installed were developed for OS 6.0 and above devices and so won't work on your OS 5.0 9000.

 

There is no OS 6.0 upgrade for the 9000.  So if you want to use these programs either find a version that was developed for OS 5.0 or get a newer device. 

New Contributor
Posts: 2
Registered: ‎03-10-2013
My Device: Bold 9000
My Carrier: 841644517966

Re: How to install 'net.rim.device.api.command.Command'?

Oh thank you so much! I've been on Google for days... I'll try another version of this app...

Thank you once again!

All the best,