Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 154
Registered: ‎01-08-2010
My Device: 8310 Rogers
My Carrier: Vodafone

How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

Hi

 

We have created a small blackberry application using Eclipse version 3.4.1.

 

It has Blackberry JDE component package of 4.5.0.

 

For testing we are using 8310 Rogers (4.2.2.163 (8310-Rogers))

 

How do we test the same application on different device simulator having different os i.e. 4.6?

 

How do we make the application compatible with devices having os 4.6?

 

Please help.

 

Thanks.

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

you can run it on all devices with a higher OS. just copy the cod to the simulator and run it.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 154
Registered: ‎01-08-2010
My Device: 8310 Rogers
My Carrier: Vodafone

Re: How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

Hi

 

Okay. So the application created using JDE 4.5 can run on devices with higher OS?

 

I have installed eclipse using BlackBerry_JDE_PluginFull_1.0.0.67.exe and it gives me JDE 4.5.

 

is ther any wway I can cretae my application using JDE 4.5?

 

One more thing JDE 4.5 means OS 4.5 or what?

 

Please help.

 

Thanks   

 

 

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

yes, the jde and the os version correspond. you can switch your eclipse plugin to use the 4.5. one exception would be the storm 1/2, you have to use 4.7+ for your application not getting switched into compatibility mode (but it runs nonetheless)
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 154
Registered: ‎01-08-2010
My Device: 8310 Rogers
My Carrier: Vodafone

Re: How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

Hi

 

Thanks for quick reply.

 

My eclipse currently uses JDE 4.5.

 

How can I switch it to use JDE 4.6 and test it with the device with OS 4.6?

 

Currently I test my application with 8300 Rogers which has OS 4.5.

 

Thanks.

Developer
Posts: 154
Registered: ‎01-08-2010
My Device: 8310 Rogers
My Carrier: Vodafone

Re: How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

Sorry, its 8310 Rogers and not 8300.

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: How to run application created using Blackberry JDE Component 4.5 on blackberry having 4.6 OS?

you can use the cod compiled with 4.5 and load it on the 4.6 device.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter