Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Contributor
Posts: 59
Registered: ‎07-05-2010
My Device: Blackberry 9800
My Carrier: Airtel
Accepted Solution

How to setup SDK 4.6.1 and 4.7 in the newer Eclipse Plug-in i.e version 1.5

Hi All,

 

I installed the Eclipse Plug-in 1.5 and found that RIM has removed 4.6 and 4.7 SDKs from the Eclipse update site i.e http://www.blackberry.com/go/eclipseUpdate/3.6/java.

 

Then how can i develop applications targeting those OS versions?

 

I downloaded the Component Packs 4.6.1 and 4.7 from the download page(http://us.blackberry.com/developers/javaappdev/javadevenv.jsp).

If the Component pack is of .zip format, i know how to install them.

Since they are .exe files, wondering how can i install those packages in Eclipse Plug-in?

 

Thanks,

-Nag

 

-Shankar
Highlighted
BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: How to setup SDK 4.6.1 and 4.7 in the newer Eclipse Plug-in i.e version 1.5

Versions 4.6.0, 4.6.1 and 4.7.0 are no longer supported as Eclipse plug-ins.  Any BlackBerry Smartphone running these versions of handheld software can upgrade to version 5.0.  Pre 5.0 also has very little activity in App World as shown in the stats here:  https://bdsc.webapps.blackberry.com/devzone/appworld

 

If you do need to target them for a specific reason, you can build using the BlackBerry JDE.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Regular Contributor
Posts: 59
Registered: ‎07-05-2010
My Device: Blackberry 9800
My Carrier: Airtel

Re: How to setup SDK 4.6.1 and 4.7 in the newer Eclipse Plug-in i.e version 1.5

Thanks Mark.

I found older 4.6.1 and 4.7 Plug-in folders, i copied them to the new Eclipse Plug-in folder and they are just working fine.

-Shankar