Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Trusted Contributor
Posts: 141
Registered: ‎02-15-2012
My Device: 9800
My Carrier: Airtel

Internet not running

Hi,

I am in very critical situation. When installing App in device(Bold 9700), internet is not working properly.

Even, internet is not working in browser also.

 

Please help me that what may be the problem??

 

Ankit..

Highlighted
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Internet not running

If the Internet is not working for the Browser, there is little that we can do.

 

Have you tried WiFi?

Trusted Contributor
Posts: 141
Registered: ‎02-15-2012
My Device: 9800
My Carrier: Airtel

Re: Internet not running

I am using Wi-Fi only.

I have used another device(Curve 8320). Same problem I am getting is, after installing App internet not running continously in app and in browser.

After removing App from device and restarting it, then internet working properly in browser.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Internet not running

So your app kills the Internet.  Interesting.

 

Are other apps on device working OK, like phone and email?

 

My only thought here is that this is a volume thing.  Are you thrashing the network connection?

Trusted Contributor
Posts: 141
Registered: ‎02-15-2012
My Device: 9800
My Carrier: Airtel

Re: Internet not running

yes, all other apps are working fine. The only problem is occuring after installing app in device. When I remove and restart the device, then internet again works fine.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Internet not running

Then my only thought is that your app is overusing the Network on the device.  Can you briefly describe how your application s is using the Internet?  Is the application autostarted.

 

If I was guessing right now I would say that the most likely issue is the number of network Threads that you start.  Do you try to download a number of things at once? 

Trusted Contributor
Posts: 141
Registered: ‎02-15-2012
My Device: 9800
My Carrier: Airtel

Re: Internet not running

Ok, I will describe in brief.

 

I am calling webservices in a loop. This loop depends upon data getting from webservices. At the once, when  I am caling webservices, then getting about 1000 objects. Again if loop runs according to conditions, then again it will download more than 1000 objects containing data.

 

Here, I am using internet connection.