Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Posts: 168
Registered: ‎11-22-2009
My Device: 9000 Bold, 8300 Curve

Issues with a 4.5 compiled app running fine on Torch but compiled for 6.0.. not quite as good

Just wanted to report my observations with a recent app that I built for a client. The client wanted the app to work on 4.5 and higher, but wanted to pay abit of extra attention to it working well on the Torch since it's not something that I've had the chance to work much with so far. Here's a summary of what I ran into.


-The app compiled in a 4.5 project worked fine on devices running 4.5 and up including 6.0 (Torch)

-In order to make it work for 4.5, I had to use the typical hack of drawing a black rectangle in the background so that the end of a short list field I didn't have a white background since I couldn't use the API introduced in 4.7 to simply set the background color.

-I made a new 6.0 project and compiled it to try on the Torch just to see if runs any different complied for 6.0. Using the simulator, in the background  I still had white at the end of a list field.

-In the simulator with Torch using the 6.0 project, I would get a MediaPlayerException at times when playing and switching between playing different media. On the actual device I've been unable to create the same issues, except I get the white background on the device as well.


I'm not sure if this is very useful to anyone but just wanted to report these issues. Has anyone else found any different behavior between the simulator and the device on the Torch?