Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Re: JDE 1.1

 

I keep getting the I/O (Access Denied) error. I've set permissions 100 times, no help. Set everything to read / write, no help.

 

Packaging project plantpop


C:\eclipse\plugins\net.rim.eide.componentpack4.2\bin\rapc.exe -quiet codename=deliverables\Standard\4.2.1\plantpop deliverables\Standard\4.2.1\plantpop.rapc -sourceroot=C:\projects\plantpop\plantpop\src -import=C:\eclipse\plugins\net.rim.eide.componentpack4.2\lib\net_rim_api.jar C:\projects\plantpop\plantpop\bin


I/O Error: C:\projects\plantpop\plantpop\bin (Access is denied)

 

 

anyone have advice?

Contributor
Posts: 27
Registered: ‎06-05-2010
My Device: Bold 9700
My Carrier: Rogers

Re: JDE 1.1

/bump .......ridiculous

Developer
Posts: 43
Registered: ‎10-03-2008
My Device: Not Specified

Re: JDE 1.1

/bump

 

I wonder how many people give up and move to Android and iPhone because of all these little hassles with no help from RIM.

Developer
Posts: 656
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: JDE 1.1

I have 4.3.0 installed on my eclipse version.  I had to add the rest of the SDKs by going into the Help->Install New Software windows.  Put this address in to see the other SDKs available for download :

 

http://www.blackberry.com/go/eclipseUpdate/3.5/java

 

You will need to use your BlackBerry developer login info  to complete the installation.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
Posts: 45
Registered: ‎06-23-2010
My Device: Not Specified

Re: JDE 1.1

The 4.3.0 is not available through eclipse update site currently. Btw, this should make things clear about support for older component packs: https://www.blackberry.com/jira/browse/TOOL-184 .

 

Regards.

Developer
Posts: 1,305
Registered: ‎01-21-2009
My Device: Not Specified

Re: JDE 1.1

That issue is not accessible to all developers. I just get a PERMISSION VIOLATION notice with a lot of red on the screen. Smiley Sad




Solved? click "Accept as solution". Helpful? give kudos by clicking on the star.
Contributor
Posts: 12
Registered: ‎12-23-2009
My Device: BB Bold 9700
My Carrier: WIND Mobile

Re: JDE 1.1

[ Edited ]

@

 

http://www.blackberry.com/go/eclipseUpdate)https://www.blackberry.com/Downloads/browseSoftware.do)

 

 

BlackBerry JDE Component Package 4.2.1

|_bin

|_lib

|_ComponentRedistribution.txt

 

Directory structure of an eclipse component pack:

net.rim.eide.componentpack4.7.0_4.7.0.46

|_components

   |_bin

   |_docs

   |_ESS

   |_lib

   |_MDS

   |_META-INF

   |_samples

   |_simulator

   |_BlackBerry SDK License Agreement 030608 cl.rtf

   |_ComponentRedistribution.txt

   |_dummy.txt

|_META-INF

|_about.ini

|_about.mappings

|_about.properties

|_BlackBerryJDE.gif

|_plugin.properties

|_plugin.xml

 

Do you see an easier approach?

Shaheen,
Inkrypt Technologies Corp.
Developer
Posts: 1,305
Registered: ‎01-21-2009
My Device: Not Specified

Re: JDE 1.1

Well, I never got that .ee approach working, and nobody else had too much more success. Moreover, RIM has issued an updated plug-in. I don't see an easier approach to what you're trying, and, given the history of this, I'm not too sanguine about anything working at this point. But good luck!

 

Our web site statistics show that pre-4.5 devices now account for only a very small and shrinking fraction of our visitors. The next version of our software will definitely not target anything before 4.5, and maybe only 5.0 and above (since we don't expect to issue it for several months). My guess is that RIM, while not wanting to make any such announcement, considers pre-4.5 device software obsolete.




Solved? click "Accept as solution". Helpful? give kudos by clicking on the star.
Contributor
Posts: 12
Registered: ‎12-23-2009
My Device: BB Bold 9700
My Carrier: WIND Mobile

Re: JDE 1.1

You're right, it was Matty who reported that the .ee file approach worked. I agree with what you said, at this point, pre-4.5 is a bit ancient. However, there are some of us who may need to support users running older software, and here are some updates from my trials;

 

The old Java Plug-in for Eclipse update site was decommissioned (I tried using Eclipse 3.4 + 1.0 plugin, and using Eclipse 3.5 and 1.1.2 plugin).

 

The new update site for Eclipse 3.5 (at http://www.blackberry.com/go/eclipseUpdate/3.5/java) serves up component packs 4.5 and up.

 

For an all-in-one solution, using Eclipse 3.5, the new 1.1 BB Java Plug-in, and the ability to compile against component packs 4.2.1, 4.3.0, and up, you can utilize the BlackBerry Java Plug-in for Eclipse 3.5 BETA Update Site available at http://na.blackberry.com/eng/developers/devbetasoftware/jar/3.5/java

 

Note: I was able to install the 4.2.1 component pack and compile my source using it.

 

This and other options for pre-4.5 development are detailed at https://tech.lds.org/wiki/index.php/Gospel_Library_for_BlackBerry_getting_started

Shaheen,
Inkrypt Technologies Corp.
Contributor
Posts: 42
Registered: ‎02-10-2010
My Device: Nexus One (Android)
My Carrier: AT&T

Re: JDE 1.1

Hi  lnkrypt,

 

Thank you for the info and links to the BETA update site! It was exactly what I needed. The BETA update site allowed me to download the 4.2.1 SDK

 

THANK YOU!

~Chris
PuguaSoft LLC