Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 16
Registered: ‎08-29-2008
My Device: Not Specified
Accepted Solution

JDE 4.5.0 Rimlet Installation compatability issues on older BB devices

Hi,

 

I have written a Rimlet using the JDE 4.5.0 and am hitting compatability issues when installing the application on older BB devices. For example, trying to install on a 8100 series device, i have so far also had to include net_rim_xml_org.cod

to the installation package. Now i'm getting the following error:

 

 Class 'net.rim.device.api.ui.component.keywordFilterField' not found.

 

I know why this is. But I'm not sure what the best thing to do is. I expect that trying to replace specific older versions of runtime libraries would not be the right thing to do.

 

Should I just not bother using JDE 4.5.0 for five years or is there some standard runtime redistributable library that I can safely include in my installation that will make all my problems go away?

 

 

 

 

 

Highlighted
Developer
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: JDE 4.5.0 Rimlet Installation compatability issues on older BB devices

If you are using JDE 4.5.0 then your compiled application will run on devices with operating system version >= 4.5.0

For example if you've compiled an app on JDE 4.5.0it will run on devices with OS versions: 4.5.0, 4.5.1, 4.5.2, ..., 4.6.0 etc

 

If you try to run this app on device with OS version less than version of your JDE you'll get an runtime error.

----------------
if your issue solved set "Solution" mark at the relevant post
New Developer
Posts: 22
Registered: ‎07-17-2008
My Device: Not Specified

Re: JDE 4.5.0 Rimlet Installation compatability issues on older BB devices

Unfortunately, you need to pick a baseline OS and stick with that.  The original pearl is 4.2.0 and there are still a lot of those.  Not too many of the prior 8700 and 7130 that ran 4.1 though.  You can also have multiple OS specific builds.  I have separate builds for 4.2.0, 4.2.1, and 4.6.0, each one of which is slightly different.
Developer
Posts: 16
Registered: ‎08-29-2008
My Device: Not Specified

Re: JDE 4.5.0 Rimlet Installation compatability issues on older BB devices

ok thx for that. was afraid that might be the case.

New Developer
Posts: 2
Registered: ‎07-31-2008
My Device: Not Specified

Re: JDE 4.5.0 Rimlet Installation compatability issues on older BB devices

I still see a fair amount of customers with 4.1 devices (even some very big Wall St. banks with lots of money to spend on hardware).

Our company still uses 4.1 as the oldest OS we still have to support.