Thank you for visiting the BlackBerry Support Community Forums.
BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)
BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.
"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."
- Kevin Michaluk, Founder, CrackBerry.com
Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.
08-29-2008 09:36 AM
I have written a Rimlet using the JDE 4.5.0 and am hitting compatability issues when installing the application on older BB devices. For example, trying to install on a 8100 series device, i have so far also had to include net_rim_xml_org.cod
to the installation package. Now i'm getting the following error:
I know why this is. But I'm not sure what the best thing to do is. I expect that trying to replace specific older versions of runtime libraries would not be the right thing to do.
Should I just not bother using JDE 4.5.0 for five years or is there some standard runtime redistributable library that I can safely include in my installation that will make all my problems go away?
Solved! Go to Solution.
08-29-2008 10:09 AM
If you are using JDE 4.5.0 then your compiled application will run on devices with operating system version >= 4.5.0
For example if you've compiled an app on JDE 4.5.0it will run on devices with OS versions: 4.5.0, 4.5.1, 4.5.2, ..., 4.6.0 etc
If you try to run this app on device with OS version less than version of your JDE you'll get an runtime error.
08-29-2008 02:26 PM
09-17-2008 05:57 PM
I still see a fair amount of customers with 4.1 devices (even some very big Wall St. banks with lots of money to spend on hardware).
Our company still uses 4.1 as the oldest OS we still have to support.