Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 2
Registered: ‎12-23-2008
My Device: Not Specified

JDE 4.5.0 unable to build samples

I just downloaded JDE 4.5.0 and am getting an error when trying to build the samples. 


I've seen quite a few posts on the forum about not being able to build the samples, but my my error message is different than those.


Here is the error:


Building HelloWorldDemo

C:\Program Files\Research In Motion\BlackBerry JDE 4.5.0\bin\rapc.exe  -quiet import=..\lib\net_rim_api.jar codename=com\rim\samples\device\helloworlddemo\HelloWorldDemo com\rim\samples\device\helloworlddemo\HelloWorldDemo.rapc warnkey=0x52424200;0x52525400;0x52435200 "C:\Program Files\Research In Motion\BlackBerry JDE 4.5.0\samples\com\rim\samples\device\helloworlddemo\HelloWorldDemo.java" "C:\Program Files\Research In Motion\BlackBerry JDE 4.5.0\samples\com\rim\samples\device\helloworlddemo\img\helloworld_jde.png"

java.io.IOException: Cannot run program "C:\Program" (in directory "C:\Program Files\Research In Motion\BlackBerry JDE 4.5.0\samples"): CreateProcess error=193, %1 is not a valid Win32 application

Error while building project


I've confirmed that my JDK and my JDE directories are in the Windows System Path.  I'm running Windows Vista Home Premium.


The error to me looks like it is complaining because there is a space in the path...but this is the default installation location.


Has anyone else run into this CreateProcess error=193 message? 

Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: JDE 4.5.0 unable to build samples

First, double check the PATH environment variable.


Second, try running the JDE in "Admin" mode.


I don't want to sour you on Vista, but I tried it for about 3 months with the RIM tools, and eventually gave up switched to XP. I was constantly having bizarre issues that my colleagues on XP did not have. At the end of the day, I was spending too much time trying to overcome friction caused by the OS.


Since moving to XP, my JDE issues dropped to "almost negligible".



Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: JDE 4.5.0 unable to build samples

JDE does the following:


1. Compiles your source files with javac.exe (included in Java SDK) and makes jar file.

2. Runs rapc.exe with this jar file to make cod file


The problem occured on the first step. Javac.exe was not located.


To avoid this error - add the folder with Java SDK executables to the PATH environment variable and restart JDE.


If your SDK installed in folder: C:\JavaSDK


Then executables folder is:  C:\JavaSDK\bin



New Developer
Posts: 2
Registered: ‎12-23-2008
My Device: Not Specified

Re: JDE 4.5.0 unable to build samples

I figured out the problem.  There is a bug with the JDE and Vista.  I uninstalled the JDE, then reinstalled it into a path with no spaces and everything worked.  Apparently the JDE isn't quoting the path correctly during the build step (but only under vista as my XP box works with the default location).


Thanks for the help to those that responded.