Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 157
Registered: ‎07-09-2009
My Device: Not Specified

JDE & eclipse versions for various models

Hi experts,

 

 I need to know the various JDE versions and eclipse plugin versionsfor for the following models.

 

Blackberry strom
BlackBerry Electron Models
BlackBerry Pearl Models
BlackBerry 88XX
BlackBerry Curve
BlackBerry Bold
BlackBerry Tour

 

Can anyone give the list of JDE versions and eclipse versions?

 

Thanks in advance.

Sivalingaraja

Developer
Posts: 43
Registered: ‎09-28-2009
My Device: Not Specified

Re: JDE & eclipse versions for various models

Hi sivalingaraja,

 

To clarify, you can download any simulator and have it run with any version of the JDE or eclipse plugin, or are you interested in which simulator is included in is contained by the JDE/Eclipse plugin package by default?

 

For example;

 

JDE/Eclipse Plugin 4.7 have 9500 and 9530 emulator default installed

JDE/Eclipse Plugin 4.5  -> 8100, 8110, 8120, 8130, 8300, 8310, 8320, 8330, 8700-black, 8703e, 8800, 8820, 8830

JDE/Eclipse Plugin 4.3 -> 8120, 8130

 

Regards

 

Andre

 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: JDE & eclipse versions for various models

Here is the Base release and the associated JDE/Component pack fro these devices.  Remember that these devices can be upgraded, what I have given you is the initial OS level that the device came out with:

 

Blackberry storm - Initial 4.7, use JDE/Component pack 4.7
BlackBerry Electron Models - what are these?
BlackBerry Pearl Models - there were 2 releases of Pearl

- original Pearl 8100, OS 4.2, need JDE 4.2, no associated Component Pack

- second release of 81xx models, OS 4.3, need JDE and Component pack 4.3
BlackBerry 88XX, Initial OS 4.2.1, use JDE/Component Pack 4.2.1
BlackBerry Curve, 8300 Curve was initial 4.2.2, use JDE/Component Pack 4.2.1

BlackBerry Curve, 8900 Curve was initial 4.6.1, use JDE/Component Pack 4.6

BlackBerry Bold, initial OS 4.6, use JDE/Component Pack 4.6
BlackBerry Tour, actually not sure about the Tour, think this was initially 4.7.1, use JDE/Component Pack 4.7

Developer
Posts: 157
Registered: ‎07-09-2009
My Device: Not Specified

Re: JDE & eclipse versions for various models

Thanks peter,

 

Blackberry electron models:

 

http://en.wikipedia.org/wiki/List_of_BlackBerry_Models
           Look at "Consumer models (8000 - 9000 series)" section.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: JDE & eclipse versions for various models

Electron == 8700, initially released with OS 4.1, needs JDE 4.1, no Eclipse Component pack.

 

This is a good example of how the possibility to upgrade throws a spanner in the works.

 

it is possible to upgrade your 8700 to 4.5, in which case you can use JDE 4.5 and Component Pack 4.5