Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 13
Registered: ‎01-04-2010
My Device: Not Specified
Accepted Solution

JDE dosen't start any more

Hi folks,


I developed my applikation on JDE 6.4.1.

A few days ago I installed all the other JDE for testing purpose.

Now I can't start any JDE. I deinstalled all JDEs and installed the JDE 4.6.1 again.

But it starts just one time after reinstallation. Once closed the JDE dosen't start anymore.

Same happens with all the other JDEs.



BlackBerry Development Advisor
Posts: 15,852
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: JDE doesn't start any more

Has anything else changed on your PC?  Were other versions of Java installed?  What version of JDK are you using?  What version of Windows?  Do you see any error or exception during startup?


If not, try running the following command from a command prompt within the bin directory in your BlackBerry JDE installation directory.



javaw -Xmx512M -DRIM_RUNTIME=..\lib -DRIM_BIN=..\bin -jar IDE.jar


This is the command used to start the BlackBerry JDE.  Running it from a command prompt should allow you to see any errors or exceptions are thrown during startup.


Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Posts: 1,638
Registered: ‎07-14-2008
My Device: Z10
My Carrier: Fido

Re: JDE dosen't start any more

if you had installed any simulator after installing the JDE then might be the problem.


i have this ongoing problem where i install any new sim the JDE wont start.

To fix the problem i just uninstall the sim.

Posts: 17
Registered: ‎02-25-2010
My Device: Bold 9700 OS
My Carrier: Vodafone Spain

Re: JDE dosen't start any more

Look at this



caelul // Spanish Developer
New Developer
Posts: 13
Registered: ‎01-04-2010
My Device: Not Specified

Re: JDE dosen't start any more

Thanks everybody,


deinstalling all additional simulators solved me problem.