Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 204
Registered: ‎07-09-2009
My Device: Not Specified
Accepted Solution

Loader won't install after build to work on Multiple Versions of device software, 4.2.1 on

I want to have one build of my app for all trackball / trackwheel devices, so I built using 4.2.1 JDE.

 

It installs and works correctly to a phone running a different version of device software (4.5.0), using javaloader.

 

However, after making the .alx, Desktop Software 4.7 Application Loader won't install it onto the phone.  I select the .alx and it says, "Searching for available device software", and then fails with the error, "No additional applications designed for your device were found."

 

According to the RIM website, I have to compile using the JDE corresponding to the oldest version of device software the app can run on, but it should also run on newer versions of the device software.  So, why won't the Loader install a 4.2.1 .cod on a 4.5.0 device?

 

Do I have to compile separately for every !@#$% version of the device software from 4.2.1 upward?  How would I release that as a single distrubution?  Can an .alx point to multiple .cod's and automatically select the right one for the phone?

 

Again, the app installs and runs perfectly using javaloader.  It's a 4.2.1 build running on a 4.5.0 Curve 8330.

 

Thanks in advance experts for the help.

Highlighted
Developer
Posts: 204
Registered: ‎07-09-2009
My Device: Not Specified

Re: Loader won't install after build to work on Multiple Versions of device software, 4.2.1 on

 OK, forget the question Smiley Happy

 

It looked like it was giving an error like it was incompatible with the device, but it still added the app to the list.  I clicked the check box and it installed.  Sorry people, I'm a rookie obviously  :-D