Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 455
Registered: ‎01-14-2009
My Device: Apple iPhone 3GS 16GB

Lost data in persistent store

Hello,

 

I am storing some information in a persistent store. When i build and run ,the simulator sometimes shows some thing like a license agreement, and then it rearranges all the icons in the bold simulator. It also loses all the data in the persistent store as well.I have no idea why it happens as persistent stores are supposed to store data which persists even when the device is reset.

 

I am using Blackberry JDE version 4.7.0.41 and a Bold Simulator(9000)

 

Please help.
Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Lost data in persistent store

This is a normal occurrence if you select "erase simulator file" in the JDE.

 

I have never seen a spontaneous erasure of the file system on the simulator, though.

 

Developer
Posts: 455
Registered: ‎01-14-2009
My Device: Apple iPhone 3GS 16GB

Re: Lost data in persistent store

Ok. I did guess that. But i didnt actually erase it. It got erased Automatically . Hope that it wouldnt happen in the device. I am yet to test it on an actual Device.
Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: Lost data in persistent store

If you are coding for a Bold, you should be using JDE 4.6, not 4.7.  Remember that the OS Level of the device decides the JDE level, JDE must be same or earlier.  So recompile in the correct JDE and I suspect your problems will be resolved. 

 

Like RexDoug, I've yet to see a device loose persistent storage.  If you do see it, I would suspect your code before suspecting the device.