Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 5
Registered: ‎09-15-2008
My Device: Not Specified

MIDlet application won't start

I'm using version 4.5.0 of the JDE. 

 

I've written a very simple application which extends midlet. I've added a breakpoint in JDE on the first line inside startApp(). This breakpoint never gets hit.

 

I have created a workspace, which contains one project, which contains 3 .java files, only one of which is a MIDlet.

 

Inside the JDE I build (which succeeds), hit F5 and the simulator comes up and goes to the main BlackBerry screen. My application never starts. I've tried loading the .cod file inside the simulator. It didn't work. I tried looking for my application in the Applications menu in the simulator. It wasn't there.

 

So my question is, what do I have to do to get the application to start up and be executed within the simulator?

 

I've read the developer guide (development.pdf) in the developer section of this web site. I've also read the help (via F1 in JDE) for how to test applications in JDE and the simulator. I did what it suggested, but nothing happens when I do.

 

Thanks in advance. 

Highlighted
BlackBerry Development Advisor
Posts: 15,806
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: MIDlet application won't start

Please ensure that you have changed your project's properties from the default setting of BlackBerry CLDC application to MIDlet.  Failing to do so can prevent your application icon from appearing (since it is a MIDlet).

 

You can change this by right clicking on your project, selecting project properties and then clicking on the application tab.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.