Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 87
Registered: ‎08-25-2009
My Device: Not Specified

Max API versions for specific phones

In trying to support multiple OS levels, I was wondering, what are some blackberry phones on the maket and their respective max OS levels? I recently tried to update my Curve 8520, and it seems I have the most recent version for the device: v4.6.1.259.I assume it will not be receiving an update, and was wondering what the last API level for other devices was.

 

Thanks

Highlighted
Developer
Posts: 77
Registered: ‎01-27-2010
My Device: Bold 9000
My Carrier: AT&T

Re: Max API versions for specific phones

Wikipedia has a list like that.  And yes  4.6 is the highest version for your device.

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Max API versions for specific phones

Curve 83xx - 4.5 (even though I have some customers that have gotten 5.0 onto it. Not sure how)

Bold 90xx, Bold 9700, Curve 85xx, Curve 89xx, Storm 95xx - 5.0

 

Some of these may work with 6.0 when it is released but the details have yet to officially be announced.

 

It is better to not depend on a specific device max level since the OS is forward-compatible. Build with lowest common denominator in mind and add features for later OS as needed.

 

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Max API versions for specific phones

[ Edited ]

 


Adama wrote:

Wikipedia has a list like that.  And yes  4.6 is the highest version for your device.


OS 4.6 is actually not the highest for an 8520. A simple Google search would tell you otherwise. Unfortunately, that Wikipedia article needs to be updated.

 

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Developer
Posts: 87
Registered: ‎08-25-2009
My Device: Not Specified

Re: Max API versions for specific phones

[ Edited ]

What is your lowest common denominator, 4.2?

 

EDIT: 4.5 is the lowest JRE they offer right? How old are phones that support less than 4.5?

 

 

Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Max API versions for specific phones

[ Edited ]

4.5 is the lowest in the latest version of Eclipse plug-in. You can use older JDEs or the older Eclipse plugin to get 4.2 in.

 

There are some Curve 83xx, 88xx or Pearl devices that still may have 4.2 or 4.3 on them as well as non-named devices mentioned in the Wikipedia article.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful