Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Contributor
Posts: 81
Registered: ‎01-14-2011
My Device: Curve 8530
My Carrier: Cricket

Missing classes...net.rim.device.api.io.parser.soap

net.rim.device.api.io.parser.soap
Class SOAPBody

java.lang.Object
  extended by net.rim.device.api.io.parser.soap.SOAPElement
      extended by net.rim.device.api.io.parser.soap.SOAPElementContainer
          extended by net.rim.device.api.io.parser.soap.SOAPBody

In the SDK it has that tree, however, even with my Eclipse having all the latest downloaded and installed plugins from BB, I do not have an import for the parser at all, under IO, I only have

 

file

http

transport

transport.options

 

I want to use the native SOAP component so I can work with .NET without any special unsigned or otherwise items, how or where do I get that so I can get this to work?

 

BlackBerry Java JDK 6.0.0.30
BlackBerry Java Plug-in 1.3.0.201101051005-15
BlackBerry JRE 6.0.0
Eclipse: Helios

Developer
Posts: 604
Registered: ‎12-27-2010
My Device: Not Specified

Re: Missing classes...net.rim.device.api.io.parser.soap

These classes don't exist in the 5.0 API, they're in 6.0. Here's the link to the 5.0 documentation http://www.blackberry.com/developers/docs/5.0.0api/index.html

Regular Contributor
Posts: 81
Registered: ‎01-14-2011
My Device: Curve 8530
My Carrier: Cricket

Re: Missing classes...net.rim.device.api.io.parser.soap

Documentation does not help, I need the correct download, I have installed all that I can install on Eclipse and JDE 6.0 also, what I need is a LINK to download and install the plugins or what ever. I know where to go to read about them all day long, what I do not know is how to obtain them. They are not in JDE 6.0, they are not in the downloads from using Eclipse to pull them from Blackberry servers, so where do I find them?

BlackBerry Java JDK 6.0.0.30
BlackBerry Java Plug-in 1.3.0.201101051005-15
BlackBerry JRE 6.0.0
Eclipse: Helios

Highlighted
Developer
Posts: 604
Registered: ‎12-27-2010
My Device: Not Specified

Re: Missing classes...net.rim.device.api.io.parser.soap

If you are trying to do this in a pre-6.0 environment then you may consider using kSOAP http://ksoap2.sourceforge.net/. Also, I linked you to the documentation because your sig says you're developing for a 5.0 JDK and asking questions about something that is not part of it. If that is not the case, which one are you using so we can give you appropriate responses.

Regular Contributor
Posts: 81
Registered: ‎01-14-2011
My Device: Curve 8530
My Carrier: Cricket

Re: Missing classes...net.rim.device.api.io.parser.soap

I am / was using the 1.1 release of the Java download for Eclipse, just downloaded the 1.3 (what a regret this is going to be), I renamed my Eclipse folder to Eclipse_old, installed 1.3 with a fresh folder for Eclipse, opened my workspace, saw that my project all had red underscores for everything, performed the Help / Install New Software, added the

BlackBerry Java Plug-in - http://www.blackberry.com/go/eclipseUpdate/3.5/java

This got rid of all the red underscores, but nothing still builds and on top of that, I no longer have the code sign (didn't install with 1.3 apparently), so now on the Project menu, the CodeSign is gone and if I have to re-install that, I know it won't let me redo the code sign without support email back and forth, when I try to build now, all it tells me is that "There is no connected BlackBerry Device" and that is with choosing the BlackBerry Simulator.. sigh... after a few tries, it will eventually tell me "Erros in Workspace" but it doesn't go into specifics as to "what" the errors are, if I say "Proceed" the Simulator does open but my program does not build up and I think it has to do with the code signing piece missing.

 

1.3.0 was not thought very well through....

BlackBerry Java JDK 6.0.0.30
BlackBerry Java Plug-in 1.3.0.201101051005-15
BlackBerry JRE 6.0.0
Eclipse: Helios

Regular Contributor
Posts: 81
Registered: ‎01-14-2011
My Device: Curve 8530
My Carrier: Cricket

Re: Missing classes...net.rim.device.api.io.parser.soap

Fixed, started over in 1.3.0, so it is in there, now to find some example code and working solutions on the thing...

BlackBerry Java JDK 6.0.0.30
BlackBerry Java Plug-in 1.3.0.201101051005-15
BlackBerry JRE 6.0.0
Eclipse: Helios